summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorGerard Salvatella <gerard.salvatella@toradex.com>2018-07-10 14:49:28 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-07-23 16:58:00 +0200
commitb34fa66b4159cb6b0952a6821e73fdb93ae7714f (patch)
tree34cd77845acdbf6f18bc5950503c035d0abffb39 /recipes-support
parent15885b9b98aff0658f962f1c61352286b0749288 (diff)
recipes: get rid of the 32-bit host binaries
Enforcing to build 32-bit binaries for native and portions thereof using -m32 in EXTRA_OEMAKE_class-native may lead to building errors. Also, it seems it's time to move on from 32-bit compatibility. Affected repositories: meta-toradex-demos meta-toradex-nxp meta-toradex-tegra Signed-off-by: Gerard Salvatella <gerard.salvatella@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.4.bb b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
index 89514e6..11013cd 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
@@ -27,7 +27,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
export PREFIX="${prefix}"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
-EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+EXTRA_OEMAKE_class-native = "CC='${CC}' CXX='${CXX}'"
do_compile() {
sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile