summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-06-19 09:54:51 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-06-19 09:54:51 +0200
commit2a172da3a6d900fb00c3f85c124b49ae59e22294 (patch)
tree9eb8ca9efb9a627d51673d401f626ee69a28f991 /recipes
parent1e276c30d54e58b4720b5a963b696e6de8e77dab (diff)
Add binary package of GPIOConfig, Tegrastats
Add udev-late-mount
Diffstat (limited to 'recipes')
-rwxr-xr-xrecipes/tegrastats/files/Tegrastats-gtk.desktop11
-rw-r--r--[-rwxr-xr-x]recipes/tegrastats/files/tegrastatsbin10000 -> 18636 bytes
-rw-r--r--recipes/tegrastats/files/tegrastats-gtkbin0 -> 15436 bytes
-rw-r--r--recipes/tegrastats/tegrastats.bb33
4 files changed, 25 insertions, 19 deletions
diff --git a/recipes/tegrastats/files/Tegrastats-gtk.desktop b/recipes/tegrastats/files/Tegrastats-gtk.desktop
new file mode 100755
index 0000000..5424c2a
--- /dev/null
+++ b/recipes/tegrastats/files/Tegrastats-gtk.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+
+[Desktop Entry]
+Version=1.0
+Type=Application
+Terminal=false
+Icon[C]=gnome-monitor.png
+Exec=/usr/bin/tegrastats-gtk
+Name[C]=Tegrastats-gtk
+Name=Tegrastats-gtk
+Icon=gnome-monitor.png
diff --git a/recipes/tegrastats/files/tegrastats b/recipes/tegrastats/files/tegrastats
index 1285d4d..ce8904e 100755..100644
--- a/recipes/tegrastats/files/tegrastats
+++ b/recipes/tegrastats/files/tegrastats
Binary files differ
diff --git a/recipes/tegrastats/files/tegrastats-gtk b/recipes/tegrastats/files/tegrastats-gtk
new file mode 100644
index 0000000..d105dbb
--- /dev/null
+++ b/recipes/tegrastats/files/tegrastats-gtk
Binary files differ
diff --git a/recipes/tegrastats/tegrastats.bb b/recipes/tegrastats/tegrastats.bb
index 3d40f2b..b44c4c6 100644
--- a/recipes/tegrastats/tegrastats.bb
+++ b/recipes/tegrastats/tegrastats.bb
@@ -1,26 +1,21 @@
-DESCRIPTION = "tegrastats, gives information about cpu use"
-LICENSE = "Nvidia propriatry"
-PR = "r1"
+DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output to a gtk title bar, gives information about cpu use"
+LICENSE = "CLOSED"
+PR = "r2"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
+SRC_URI = "file://tegrastats \
+ file://tegrastats-gtk \
+ file://Tegrastats-gtk.desktop "
-#SRC_URI = "file://tegrastats \
-# "
-
-S = "${WORKDIR}/target-utils/tegrastats"
-
-SVN_REV = "230"
-SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=target-utils/tegrastats;rev=${SVN_REV};proto=http"
+S = "${WORKDIR}"
PACKAGES = "${PN}"
-#FILES_${PN} =
-
-do_compile() {
- ${CC} -DNV_IS_LDK=1 ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ${S}/main.c -o tegrastats
-}
-
do_install() {
- install -d ${D}/usr/bin
- install -m 0755 ${S}/tegrastats ${D}/usr/bin
+ install -d ${D}${bindir}/ ${D}/home/root/Desktop/
+ install -m 0755 ${S}/tegrastats* ${D}${bindir}/
+ install -m 0755 ${S}/Tegrastats-gtk.desktop ${D}/home/root/Desktop/
}
+
+FILES_${PN} = " \
+ ${bindir}/tegrastats* \
+ /home/root/Desktop/Tegra* " \ No newline at end of file