summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-08-26 15:36:53 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-08-26 15:36:53 +0200
commit6f782a6d1fe8100190622d5ad36ff70280d06722 (patch)
tree083b8fcaa8653fba3ee78ee30c88dc7428fc6dac /recipes
parenteacfc89bb87d171c3087fcaf520d8968b8020e31 (diff)
xserver: move all xserver stuff in the same directory
Diffstat (limited to 'recipes')
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..6bf44ff
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,23 @@
+# When Apalis T30 is used with a external NV graphics card, the binary
+# only driver fails (the dynamic linker can not resolve all symbols),
+# when xinerama is disabled in the X server
+
+# adapted from meta-fsl-arm/recipes-graphics/mesa/
+python __anonymous () {
+ import re
+
+ cur_machine = d.getVar('MACHINE', True)
+ if cur_machine == 'apalis-t30':
+ # Remove --disable-xinerama from EXTRA_OECONF
+ extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
+ take_out = ['--disable-xinerama']
+ new_extra_oeconf = []
+ for i in extra_oeconf:
+ if i not in take_out:
+ new_extra_oeconf.append(i)
+
+ d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
+
+ # We are now machine specific
+ d.setVar('PACKAGE_ARCH', d.getVar('MACHINE_ARCH'))
+}