summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb2
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb2
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm/0001-configure.ac-link-crypotpp-as-a-static-library.patch2
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.4.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index ee94a00..7367c4b 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -15,7 +15,7 @@ PV = "1.7"
EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
#we want cbootimage binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
-EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -m32' 'BUILDDIR=${S}'"
+EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index b4864dd..2d17bdb 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -25,7 +25,7 @@ EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
LDFLAGS_append = " -static-libstdc++"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
-EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+EXTRA_OEMAKE_class-native = "CC='${CC}' CXX='${CXX}'"
EXTRA_OEMAKE_class-nativesdk = "CC='${CC}' CXX='${CXX}'"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/tegrarcm/tegrarcm/0001-configure.ac-link-crypotpp-as-a-static-library.patch b/recipes-bsp/tegrarcm/tegrarcm/0001-configure.ac-link-crypotpp-as-a-static-library.patch
index 5e38ae8..bdafb55 100644
--- a/recipes-bsp/tegrarcm/tegrarcm/0001-configure.ac-link-crypotpp-as-a-static-library.patch
+++ b/recipes-bsp/tegrarcm/tegrarcm/0001-configure.ac-link-crypotpp-as-a-static-library.patch
@@ -20,7 +20,7 @@ index c95a0ec..250f3c2 100644
AC_LANG(C++)
SAVED_LDFLAGS=$LDFLAGS
-LDFLAGS="$LDFLAGS -lcryptopp -lpthread"
-+LDFLAGS="$LDFLAGS -m32 -Wl,-Bstatic -lcryptopp -Wl,-Bdynamic -lpthread"
++LDFLAGS="$LDFLAGS -Wl,-Bstatic -lcryptopp -Wl,-Bdynamic -lpthread"
CRYPTOLIB=
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([#include <cryptopp/cryptlib.h>],
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.4.bb b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
index 89514e6..11013cd 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
@@ -27,7 +27,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
export PREFIX="${prefix}"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
-EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+EXTRA_OEMAKE_class-native = "CC='${CC}' CXX='${CXX}'"
do_compile() {
sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile