summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/tegra-u-boot-localversion.bbclass29
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb1
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb1
3 files changed, 31 insertions, 0 deletions
diff --git a/classes/tegra-u-boot-localversion.bbclass b/classes/tegra-u-boot-localversion.bbclass
new file mode 100644
index 0000000..fba638c
--- /dev/null
+++ b/classes/tegra-u-boot-localversion.bbclass
@@ -0,0 +1,29 @@
+# Toradex Tegra U-Boot LOCALVERSION extension
+#
+# This allow to easy reuse of code between different U-Boot recipes
+#
+# The following options are supported:
+#
+# SCMVERSION Puts the Git hash in U-Boot local version
+# LOCALVERSION Value used in LOCALVERSION (default to '+fslc')
+#
+# Copied from meta-freescale/classes/fsl-u-boot-localversion.bbclass
+# Copyright 2014 (C) O.S. Systems Software LTDA.
+# Copyright 2017 (C) Toradex Inc.
+
+SCMVERSION ??= "y"
+LOCALVERSION ??= "-${TDX_VER_INT}"
+
+UBOOT_LOCALVERSION = "${LOCALVERSION}"
+
+do_compile_prepend() {
+ if [ "${SCMVERSION}" = "y" ]; then
+ # Add GIT revision to the local version
+ head=`cd ${S} ; git rev-parse --verify --short HEAD 2> /dev/null`
+ printf "%s%s%s" "${UBOOT_LOCALVERSION}" +g $head > ${S}/.scmversion
+ printf "%s%s%s" "${UBOOT_LOCALVERSION}" +g $head > ${B}/.scmversion
+ else
+ printf "%s" "${UBOOT_LOCALVERSION}" > ${S}/.scmversion
+ printf "%s" "${UBOOT_LOCALVERSION}" > ${B}/.scmversion
+ fi
+}
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 0666387..6a1eece 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -6,6 +6,7 @@ PROVIDES = "u-boot-fw-utils"
DEPENDS = "mtd-utils"
include conf/tdx_version.conf
+inherit tegra-u-boot-localversion
COMPATIBLE_MACHINE = "(apalis-t30|apalis-tk1|colibri-t20|colibri-t30)"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index bf715a7..06ae5d1 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -1,5 +1,6 @@
require recipes-bsp/u-boot/u-boot.inc
include conf/tdx_version.conf
+inherit tegra-u-boot-localversion
PROVIDES = "u-boot virtual/bootloader"
DEPENDS += "dtc-native"