summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xrecipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb31
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend26
2 files changed, 23 insertions, 34 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
index 75d4076..5e26b33 100755
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
@@ -1,5 +1,13 @@
+# always latest and greatest.
+
require recipes-graphics/xorg-xserver/xserver-xorg.inc
+COMPATIBLE_MACHINE = "(tegra124)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PE = "99"
+
+DEPENDS_append = " libxfont"
+
SRC_URI[md5sum] = "1509a9daae713895e7f5bcba8bcc05b2"
SRC_URI[sha256sum] = "0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457"
@@ -29,18 +37,25 @@ RCONFLICTS_${PN} = "${PN}-extension-dri \
${PN}-extension-extmod \
${PN}-extension-dbe \
"
-# provided by xf86-input-evdev_2.10.0
-do_install_append () {
- rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
-}
-# override setting from xserver-xorg.inc which only applies to version 1.18.
+# The NVidia driver needs xinerama enabled.
+
+# override setting from xserver-xorg.inc which only applies to version 1.18
+# remove systemd:
#| checking for PIXMAN... yes
#| checking for SYSTEMD_DAEMON... no
#| configure: error: systemd support requested but no library has been found
#| ERROR: Function failed: do_configure (log file is located at /build/krm/oe-core_V2.6.2/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
-PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
+# provide dga to prevent runtime error
+# X: symbol lookup error: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: DGAInit
+
+PACKAGECONFIG ?= "dga dri2 udev xinerama ${XORG_CRYPTO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri', '', d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "opengl wayland", "xwayland", "", d)} \
"
+
+# provided by xf86-input-evdev_2.10.0
+do_install_append () {
+ rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
+}
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend
deleted file mode 100644
index 9a577a8..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
-# always latest and greatest.
-PE_tegra124 = "99"
-
-PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
-
-COMPATIBLE_MACHINE = "(apalis-tk1|jetson-tk1|jetson-tk1-l4t)"
-
-DEPENDS_append = " libxfont"
-
-# provided by xf86-input-evdev_2.10.0
-do_install_append () {
- rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
-}
-
-#| checking for PIXMAN... yes
-#| checking for SYSTEMD_DAEMON... no
-#| configure: error: systemd support requested but no library has been found
-#| ERROR: Function failed: do_configure (log file is located at .../xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
-
-PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
-"
-
-# The NVidia driver needs this enabled.
-PACKAGECONFIG_append = " xinerama "