summaryrefslogtreecommitdiff
path: root/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.2.bb')
-rw-r--r--recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.2.bb b/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.2.bb
new file mode 100644
index 0000000..08cc8f0
--- /dev/null
+++ b/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Toradex Apalis TK1 K20 MCU Firmware"
+HOMEPAGE = "https://developer.toradex.com/"
+LICENSE = "FREESCALE_SEMICONDUCTOR_SOFTWARE_LICENSE_AGREEMENT"
+
+SRC_URI = "file://apalis-tk1-k20.bin \
+ file://LICENCE \
+ "
+
+LIC_FILES_CHKSUM = "file://../LICENCE;md5=a1b1cf31b1b3d185409f31cb9beb25dc"
+
+PR = "r0"
+
+FILES_${PN} = " /lib/firmware/apalis-tk1-k20.bin "
+
+do_install () {
+ install -d ${D}/lib/firmware/
+ install -m 0644 ${WORKDIR}/apalis-tk1-k20.bin ${D}/lib/firmware/
+}