summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb75
1 files changed, 0 insertions, 75 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
deleted file mode 100644
index 87e2ec3..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ /dev/null
@@ -1,75 +0,0 @@
-SUMMARY = "U-boot bootloader fw_printenv/setenv utils"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-SECTION = "bootloader"
-PROVIDES = "u-boot-fw-utils"
-RPROVIDES_${PN} = "u-boot-fw-utils"
-DEPENDS = "mtd-utils"
-
-inherit tegra-u-boot-localversion
-
-COMPATIBLE_MACHINE = "(apalis-tk1)"
-
-FILESPATHPKG =. "git:"
-
-# This revision is based on upstream "v2016.11"
-SRCREV = "83a53c1c0c6fd813bd655b4f88fd07bf798e11d7"
-SRCBRANCH = "2016.11-toradex"
-SRCREV_use-head-next = "${AUTOREV}"
-SRCBRANCH_use-head-next = "2016.11-toradex-next"
-SRC_URI = " \
- git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
- file://default-gcc.patch \
- file://0001-libfdt-move-headers-to-linux-libfdt.h-and-linux-libf.patch \
- file://fw_env.config \
- file://fw_unlock_mmc.sh \
-"
-
-PV = "2016.11+git${SRCPV}"
-PR = "${TDX_VER_ITEM}"
-
-S = "${WORKDIR}/git"
-
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
-
-inherit pkgconfig uboot-config
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
-}
-
-do_install () {
- install -d ${D}${base_sbindir} ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
-}
-
-install_unlock_emmc() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
-}
-
-do_install_append_tegra124() {
- install_unlock_emmc
-}
-
-do_install_append_tegra124m() {
- install_unlock_emmc
-}
-
-do_install_class-cross () {
- install -d ${D}${bindir_cross}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
-}
-
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-# defaults
-TDX_VER_ITEM ??= "0"