summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 56caa08..ee1c748 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -6,7 +6,6 @@ PROVIDES = "u-boot-fw-utils"
RPROVIDES_${PN} = "u-boot-fw-utils"
DEPENDS = "mtd-utils"
-include conf/tdx_version.conf
inherit tegra-u-boot-localversion
COMPATIBLE_MACHINE = "(apalis-tk1)"
@@ -71,3 +70,6 @@ do_install_class-cross () {
SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# defaults
+TDX_VER_ITEM ??= "0"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index 9237c6a..610c437 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -1,6 +1,5 @@
require recipes-bsp/u-boot/u-boot.inc
require recipes-bsp/u-boot/u-boot-toradex-env.inc
-include conf/tdx_version.conf
inherit tegra-u-boot-localversion
PROVIDES = "u-boot virtual/bootloader"
@@ -51,3 +50,6 @@ do_deploy_append_apalis-tk1-mainline() {
cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
}
+
+# defaults
+TDX_VER_ITEM ??= "0"