summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/lvds-ctrl/files/lvds-single-channel-24bit-mode2.sh11
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb1
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes-bsp/lvds-ctrl/files/lvds-single-channel-24bit-mode2.sh b/recipes-bsp/lvds-ctrl/files/lvds-single-channel-24bit-mode2.sh
new file mode 100644
index 0000000..a4e5312
--- /dev/null
+++ b/recipes-bsp/lvds-ctrl/files/lvds-single-channel-24bit-mode2.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+#enable the parallel RGB to LVDS controller in single channel mode
+
+echo high > /sys/class/gpio/gpio216/direction
+echo low > /sys/class/gpio/gpio219/direction
+echo high > /sys/class/gpio/gpio222/direction
+echo low > /sys/class/gpio/gpio223/direction
+echo high > /sys/class/gpio/gpio226/direction
+echo high > /sys/class/gpio/gpio225/direction
+echo high > /sys/class/gpio/gpio221/direction
+echo high > /sys/class/gpio/gpio220/direction
diff --git a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
index 7632bb9..dc1d49c 100644
--- a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
@@ -4,6 +4,7 @@ LICENSE = "PD"
SRC_URI = " \
file://lvds-dual-channel.sh \
file://lvds-single-channel.sh \
+ file://lvds-single-channel-24bit-mode2.sh \
file://COPYING \
"