summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb4
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc22
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend (renamed from recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb)14
4 files changed, 4 insertions, 38 deletions
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index 440ef6c..d882cb5 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -3,12 +3,12 @@ DESCRIPTION = "Utility to create boot images with boot configuration data (BCT)
SECTION = "bootloader"
DEPENDS = ""
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
BBCLASSEXTEND = "native nativesdk"
-SRC_URI = "git://github.com/NVIDIA/cbootimage.git"
+SRC_URI = "git://github.com/NVIDIA/cbootimage.git;branch=master;protocol=https"
SRCREV = "a64c3f12b1b048096d90c44db74d3d110cea6fff"
PV = "1.7"
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 02c789e..30a955b 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=395fe5affb633ad84474e42989a8e5be"
BBCLASSEXTEND = "native nativesdk"
SRC_URI = " \
- git://github.com/NVIDIA/tegrarcm.git \
+ git://github.com/NVIDIA/tegrarcm.git;branch=master;protocol=https \
file://0001-makefile-specify-cryptopp-include-path-relative-to-s.patch \
"
SRC_URI:append:class-native = " \
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc b/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc
deleted file mode 100644
index 14a4db0..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-DEPENDS += "flex-native bison-native"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
-PE = "1"
-
-PV = "2020.07+git${SRCPV}"
-inherit toradex-u-boot-localversion
-
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "0401650db5dfaf5fe67cb2ed8e9285bb198f3245"
-SRCBRANCH = "toradex_2020.07"
-SRCREV:use-head-next = "${AUTOREV}"
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-
-S = "${WORKDIR}/git"
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb b/recipes-bsp/u-boot/u-boot_%.bbappend
index 7e772bf..fcd3a4d 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,27 +1,15 @@
-require u-boot-toradex-common-tk1.inc
-require recipes-bsp/u-boot/u-boot.inc
-
-B = "${WORKDIR}/build"
-
-DEPENDS += "bc-native dtc-native"
+FILESEXTRAPATHS:prepend := "${THISDIR}//files:"
DEPENDS:append:apalis-tk1 = " cbootimage-native"
-PROVIDES += "u-boot"
-
-COMPATIBLE_MACHINE = "(apalis-tk1)"
-
SRC_URI:append:apalis-tk1 = " \
file://apalis-tk1.img.cfg \
file://fw_env.config \
file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
do_deploy:append:apalis-tk1() {
cd ${DEPLOYDIR}
cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
}
-