summaryrefslogtreecommitdiff
path: root/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/hdmi-hotplug/hdmi-hotplug.bb')
-rw-r--r--recipes-core/hdmi-hotplug/hdmi-hotplug.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-core/hdmi-hotplug/hdmi-hotplug.bb b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
new file mode 100644
index 0000000..ee89956
--- /dev/null
+++ b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
@@ -0,0 +1,20 @@
+SECTION = "core"
+DESCRIPTION = "Use xrandr after a HDMI hotplug event has been detected to switch the display on"
+RDEPENDS_${PN} = ""
+# The license is meant for this recipe and the files it installs.
+# RNDIS is part of the kernel, udhcpd is part of busybox
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r1"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = " \
+ file://hdmi.rules \
+"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/hdmi.rules ${D}/${sysconfdir}/udev/rules.d/
+}