summaryrefslogtreecommitdiff
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend14
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c34c789..b3f960f 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,13 +1,17 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
#####
# tegra tk1
-DEPENDS_append_tegra124= " linux-driver-package"
-SRC_URI_append_tegra124 = " file://0001-pkg-config-files-add-tegra-paths.patch"
-
PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+PROVIDES_remove_tegra124 = "virtual/egl virtual/libgl virtual/libgles1 virtual/libgles2"
+
+do_install_append_tegra124 () {
+ rm ${D}${libdir}/libEGL.so*
+ rm ${D}${libdir}/libGL.so*
+ rm ${D}${libdir}/libGLESv1*.so*
+ rm ${D}${libdir}/libGLESv2.so*
+}
+
#####
## Tegra TK1 mainline kernel