summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
index 1932761..ad9e10b 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
@@ -21,11 +21,14 @@ inherit autotools-brokensep pkgconfig
EXTRA_OECONF = "--libdir=${base_libdir}"
+#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+
do_compile() {
sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
oe_runmake -f GNUmakefile
- oe_runmake libcryptopp.so
+ oe_runmake libcryptopp.a
}
do_install_prepend() {