summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.4.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.4.bb b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
index 68ce50f..c537781 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
@@ -20,13 +20,13 @@ SRC_URI[sha256sum] = "be430377b05c15971d5ccb6e44b4d95470f561024ed6d701fe3da3a188
inherit autotools-brokensep pkgconfig
-PACKAGES_prepend = "${PN}-test "
+PACKAGES:prepend = "${PN}-test "
EXTRA_OECONF = "--libdir=${base_libdir}"
TARGET_CC_ARCH += "${LDFLAGS}"
export PREFIX="${prefix}"
-EXTRA_OEMAKE_class-native = "CC='${CC}' CXX='${CXX}'"
+EXTRA_OEMAKE:class-native = "CC='${CC}' CXX='${CXX}'"
do_compile() {
sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
@@ -35,13 +35,13 @@ do_compile() {
}
# do not provide the shared object file, so we force to link statically for host tools
-do_compile_class-native() {
+do_compile:class-native() {
sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
oe_runmake all
}
-FILES_${PN}-test = " \
+FILES:${PN}-test = " \
${bindir} \
${datadir}/cryptopp \
"