summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2015-11-04 03:23:29 +0100
committerStefan Agner <stefan.agner@toradex.com>2015-11-04 03:23:29 +0100
commitf2bae7c6b33913dcad88b085285f52d0eb4474fc (patch)
tree9d8d6893c30d0dcbde393620aaacfa0ab981e776
parenta034b8069f970c54e5c202cd621976fea318d8b8 (diff)
apalis/colibri_imx6: update/load USB Gadget ConfigFS automatically
Since we use USB Gadget ConfigFS now use libusbg to load the USB Gadget configuration automatically.
-rw-r--r--recipes-kernel/linux/linux-toradex-fsl_git.bb3
-rw-r--r--recipes/images/trdx-extra.inc2
2 files changed, 4 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-toradex-fsl_git.bb b/recipes-kernel/linux/linux-toradex-fsl_git.bb
index 5dd1615..cccedd7 100644
--- a/recipes-kernel/linux/linux-toradex-fsl_git.bb
+++ b/recipes-kernel/linux/linux-toradex-fsl_git.bb
@@ -19,6 +19,9 @@ S = "${WORKDIR}/git"
SRCBRANCH_mx6 = "toradex_imx_3.14.28_1.0.0_ga"
SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH}"
+# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
+KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
+
COMPATIBLE_MACHINE = "(colibri-imx6|apalis-imx6)"
# Place changes to the defconfig here
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index b453e00..9a30d5d 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -53,7 +53,7 @@ IMAGE_INSTALL_append_colibri-t20 = " \
#meta-fsl-arm/conf/machine/include/imx-base.inc
IMAGE_INSTALL_append_mx6 = " \
u-boot-toradex-fsl-fw-utils \
- usb-rndis-systemd \
+ libusbg \
gpio-export \
curl \
file \