summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2014-04-05 10:52:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-05 11:04:48 +0200
commit3343b67eb92e86443bbb1bc13b6c54678b7a86d6 (patch)
tree4db9baad6b153c89d628fc5b03c94187cf1587fb
parent7e49db4c09fe3446e7e4322abd6ff7630c2e5fcf (diff)
u-boot-fw-utils: provide matching recipes
With the change to our own u-boot recipes the bbappend to the common u-boot-fw-utils recipe is no longer a sane solution. While at it cleanup COMPATIBLE_MACHINE style.
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb42
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb51
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb4
-rw-r--r--recipes/images/trdx-extra.inc2
4 files changed, 95 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
new file mode 100644
index 0000000..e4f88b1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM_colibri-vf = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+SECTION = "bootloader"
+PROVIDES = "u-boot-fw-utils"
+DEPENDS = "mtd-utils"
+
+COMPATIBLE_MACHINE = "(colibri-vf|apalis-imx6)"
+DEFAULT_PREFERENCE_colibri-vf = "1"
+DEFAULT_PREFERENCE_apalis-imx6 = "1"
+
+FILESPATHPKG =. "git:"
+S="${WORKDIR}/git"
+SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
+SRCREV_apalis-imx6 = "214db18e6c38454e1c4d22b472dda07db062f976"
+SRCBRANCH_colibri-vf = "colibri_vf"
+SRCBRANCH_apalis-imx6 = "toradex_imx6"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+
+PV = "${PR}+gitr${SRCREV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
new file mode 100644
index 0000000..5320f82
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
+SECTION = "bootloader"
+PROVIDES = "u-boot-fw-utils"
+DEPENDS = "mtd-utils"
+
+COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
+
+DEFAULT_PREFERENCE_colibri-t20 = "1"
+DEFAULT_PREFERENCE_colibri-t30 = "1"
+DEFAULT_PREFERENCE_apalis-t30 = "1"
+
+FILESPATHPKG =. "git:"
+S="${WORKDIR}/git"
+SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
+SRC_URI_COLIBRI += "file://u-boot-dont-build-standalone.patch"
+# This revision is based on upstream "v2011.06"
+SRCREV_COLIBRI = "ccd521c4681a5850bbec1feec140eeaec33936b0"
+
+PV_colibri-t20 = "${PR}+gitr${SRCREV}"
+PV_colibri-t30 = "${PR}+gitr${SRCREV}"
+PV_apalis-t30 = "${PR}+gitr${SRCREV}"
+
+SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
+SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
+SRC_URI_apalis-t30 = "${SRC_URI_COLIBRI}"
+
+SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
+SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
+SRCREV_apalis-t30 = "${SRCREV_COLIBRI}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index b3e06d2..92f5528 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -7,9 +7,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
-COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
-COMPATIBLE_MACHINE_colibri-t30 = "colibri-t30"
-COMPATIBLE_MACHINE_apalis-t30 = "apalis-t30"
+COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
DEFAULT_PREFERENCE_colibri-t20 = "1"
DEFAULT_PREFERENCE_colibri-t30 = "1"
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index 5ebcd01..86fde69 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -33,7 +33,7 @@ IMAGE_INSTALL_T20_T30 = " \
IMAGE_INSTALL_MACHINE_colibri-t20 = " \
${IMAGE_INSTALL_T20_T30} \
- u-boot-fw-utils \
+ u-boot-toradex-fw-utils \
kernel-module-fusion-f0710a \
"