summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-10-29 20:24:47 +0100
committerMax Krummenacher <max.oss.09@gmail.com>2015-10-29 21:51:17 +0100
commit6e791c5962b618dee02c695f80a7b2f0606f6090 (patch)
tree008d4de44436c958b6557e47c16f02b4ec491619
parentff29949fc35ec1bf831c7a953d9a749c3aa6d671 (diff)
systemd-udevd.service.in: set MountFlags=shared
-rw-r--r--recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch23
-rw-r--r--recipes-core/systemd/systemd_%.bbappend1
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch b/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
new file mode 100644
index 0000000..82fe399
--- /dev/null
+++ b/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
@@ -0,0 +1,23 @@
+From 352d8bc2ea10ca62b8301c10738429d9ed2e21cc Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.oss.09@gmail.com>
+Date: Thu, 29 Oct 2015 19:38:50 +0100
+Subject: [PATCH] systemd-udevd.service.in: set MountFlags=shared
+
+This allows for udevd automounting of drives accessible to all.
+---
+ units/systemd-udevd.service.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/units/systemd-udevd.service.in b/units/systemd-udevd.service.in
+index 2791f73..ea583e4 100644
+--- a/units/systemd-udevd.service.in
++++ b/units/systemd-udevd.service.in
+@@ -21,4 +21,4 @@ Sockets=systemd-udevd-control.socket systemd-udevd-kernel.socket
+ Restart=always
+ RestartSec=0
+ ExecStart=@rootlibexecdir@/systemd-udevd
+-MountFlags=slave
++MountFlags=shared
+--
+1.9.3
+
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 8fbdc90..a95ff82 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
SRC_URI += " \
file://rndis.network \
+ file://0001-systemd-udevd.service.in-set-MountFlags-shared.patch \
"
PACKAGECONFIG_append = " networkd"