summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README4
-rw-r--r--conf/layer.conf1
-rw-r--r--recipes-connectivity/wireless-tools/wireless-tools/avoid_strip.patch21
-rw-r--r--recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch22
-rw-r--r--recipes-connectivity/wireless-tools/wireless-tools/man.patch15
-rw-r--r--recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch19
-rw-r--r--recipes-connectivity/wireless-tools/wireless-tools_30.pre9.bb50
-rw-r--r--recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch136
-rw-r--r--recipes-lxde/gpicview/gpicview_0.2.5.bb9
-rw-r--r--recipes-lxde/images/core-image-lxde.bb36
-rw-r--r--recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb8
-rw-r--r--recipes-lxde/lxde-common/lxde-common_0.99.2.bb7
-rw-r--r--recipes-lxde/lxmenu-data/lxmenu-data/lxmenu-replace_am_glib_gnu_gettext.patch20
-rw-r--r--recipes-lxde/lxrandr/lxrandr/0001-lxrandr.c-improve-xrandr-output-parser-to-cope-with-.patch16
-rw-r--r--recipes-lxde/lxrandr/lxrandr_0.3.2.bb (renamed from recipes-lxde/lxrandr/lxrandr_0.3.1.bb)4
-rw-r--r--recipes-lxde/lxsession/lxsession_0.5.4.bb (renamed from recipes-lxde/lxsession/lxsession_0.5.3.bb)18
-rw-r--r--recipes-lxde/lxtask/lxtask_0.1.10.bb (renamed from recipes-lxde/lxtask/lxtask_0.1.8.bb)4
-rw-r--r--recipes-lxde/lxterminal/lxterminal_0.3.2.bb (renamed from recipes-lxde/lxterminal/lxterminal_0.3.1.bb)4
-rw-r--r--recipes-lxde/obconf/obconf_2.0.4+git.bb6
-rw-r--r--recipes-lxde/packagegroup/packagegroup-lxde-extended.bb1
20 files changed, 358 insertions, 43 deletions
diff --git a/README b/README
index f460eb3..667f1b2 100644
--- a/README
+++ b/README
@@ -12,13 +12,13 @@ revision: 4671a9a952bd1eab19e64d0e6efb415ead31bbf3
This layer depends on:
URI: git://git.openembedded.org/openembedded-core
-branch: rocko
+branch: master
revision: HEAD
URI: git://git.openembedded.org/meta-openembedded
meta-openembedded/meta-gnome
meta-openembedded/meta-oe
-branch: rocko
+branch: master
revision: HEAD
diff --git a/conf/layer.conf b/conf/layer.conf
index 640052a..21d5e90 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -9,3 +9,4 @@ BBFILE_PATTERN_lxde-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_lxde-layer = "7"
LAYERDEPENDS_lxde-layer = "core openembedded-layer"
+LAYERSERIES_COMPAT_lxde-layer = "dunfell gatesgarth"
diff --git a/recipes-connectivity/wireless-tools/wireless-tools/avoid_strip.patch b/recipes-connectivity/wireless-tools/wireless-tools/avoid_strip.patch
new file mode 100644
index 0000000..f34e243
--- /dev/null
+++ b/recipes-connectivity/wireless-tools/wireless-tools/avoid_strip.patch
@@ -0,0 +1,21 @@
+wireless_tools: Avoid stripping iwmulticall
+
+Upstream-Status: Inappropriate [other]
+ The removed code was from upstream.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur wireless_tools.29.orig/Makefile wireless_tools.29/Makefile
+--- wireless_tools.29.orig/Makefile 2011-06-18 11:35:12.183907453 -0500
++++ wireless_tools.29/Makefile 2011-06-18 11:38:09.995907985 -0500
+@@ -135,9 +135,8 @@
+
+ macaddr: macaddr.o $(IWLIB)
+
+-# Always do symbol stripping here
+ iwmulticall: iwmulticall.o
+- $(CC) $(LDFLAGS) -Wl,-s $(XCFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(LDFLAGS) $(STRIPFLAGS) $(XCFLAGS) -o $@ $^ $(LIBS)
+
+ # It's a kind of magic...
+ wireless.h:
diff --git a/recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch b/recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch
new file mode 100644
index 0000000..6c0d8cb
--- /dev/null
+++ b/recipes-connectivity/wireless-tools/wireless-tools/ldflags.patch
@@ -0,0 +1,22 @@
+wireless-tools: Remove QA warning: No GNU_HASH in the elf binary
+
+Upstream-Status: Inappropriate [other]
+ Useful within bitbake environment only.
+
+Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- wireless_tools.29.orig/Makefile
++++ wireless_tools.29/Makefile
+@@ -144,7 +144,7 @@ wireless.h:
+
+ # Compilation of the dynamic library
+ $(DYNAMIC): $(OBJS:.o=.so)
+- $(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
++ $(CC) -shared -o $@ -Wl,-soname,$@ $(LDFLAGS) $(STRIPFLAGS) $(LIBS) -lc $^
+
+ # Compilation of the static library
+ $(STATIC): $(OBJS:.o=.so)
diff --git a/recipes-connectivity/wireless-tools/wireless-tools/man.patch b/recipes-connectivity/wireless-tools/wireless-tools/man.patch
new file mode 100644
index 0000000..6a757da
--- /dev/null
+++ b/recipes-connectivity/wireless-tools/wireless-tools/man.patch
@@ -0,0 +1,15 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: wireless_tools.30/Makefile
+===================================================================
+--- wireless_tools.30.orig/Makefile 2014-02-01 00:21:04.148463382 -0800
++++ wireless_tools.30/Makefile 2014-02-01 00:23:35.448072279 -0800
+@@ -76,7 +76,7 @@
+ INSTALL_DIR= $(PREFIX)/sbin
+ INSTALL_LIB= $(PREFIX)/lib
+ INSTALL_INC= $(PREFIX)/include
+-INSTALL_MAN= $(PREFIX)/man
++INSTALL_MAN= $(PREFIX)/share/man
+
+ # Various commands
+ RM = rm -f
diff --git a/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch b/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
new file mode 100644
index 0000000..3a22c3f
--- /dev/null
+++ b/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
@@ -0,0 +1,19 @@
+When /etc/ld.so.cache is writeable by user running bitbake then it creates invalid cache
+(in my case libstdc++.so cannot be found after building zlib(-native) and I have to call
+touch */libstdc++.so && /sbin/ldconfig to fix it.
+
+So remove ldconfig call from make install-libs
+
+Upstream-Status: Inappropriate [disable feature]
+
+diff -uNr wireless_tools.29.orig/Makefile wireless_tools.29/Makefile
+--- wireless_tools.29.orig/Makefile 2007-09-18 01:56:46.000000000 +0200
++++ wireless_tools.29/Makefile 2012-02-15 20:46:41.780763514 +0100
+@@ -163,7 +163,6 @@
+ install -m 755 $(DYNAMIC) $(INSTALL_LIB)
+ ln -sfn $(DYNAMIC) $(INSTALL_LIB)/$(DYNAMIC_LINK)
+ @echo "*** Don't forget to add $(INSTALL_LIB) to /etc/ld.so.conf, and run ldconfig as root. ***"
+- @$(LDCONFIG) || echo "*** Could not run ldconfig ! ***"
+
+ # Install the static library
+ install-static:: $(STATIC)
diff --git a/recipes-connectivity/wireless-tools/wireless-tools_30.pre9.bb b/recipes-connectivity/wireless-tools/wireless-tools_30.pre9.bb
new file mode 100644
index 0000000..0a34207
--- /dev/null
+++ b/recipes-connectivity/wireless-tools/wireless-tools_30.pre9.bb
@@ -0,0 +1,50 @@
+SUMMARY = "Tools for the Linux Standard Wireless Extension Subsystem"
+HOMEPAGE = "https://hewlettpackard.github.io/wireless-tools/Tools.html"
+LICENSE = "GPLv2 & (LGPLv2.1 | MPL-1.1 | BSD)"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://iwconfig.c;beginline=1;endline=12;md5=cf710eb1795c376eb10ea4ff04649caf \
+ file://iwevent.c;beginline=59;endline=72;md5=d66a10026d4394f0a5b1c5587bce4537 \
+ file://sample_enc.c;beginline=1;endline=4;md5=838372be07874260b566bae2f6ed33b6"
+SECTION = "base"
+PE = "1"
+
+SRC_URI = "https://hewlettpackard.github.io/wireless-tools/wireless_tools.${PV}.tar.gz \
+ file://remove.ldconfig.call.patch \
+ file://man.patch \
+ file://avoid_strip.patch \
+ file://ldflags.patch \
+ "
+SRC_URI[md5sum] = "ca91ba7c7eff9bfff6926b1a34a4697d"
+SRC_URI[sha256sum] = "abd9c5c98abf1fdd11892ac2f8a56737544fe101e1be27c6241a564948f34c63"
+
+UPSTREAM_CHECK_URI = "https://hewlettpackard.github.io/wireless-tools/Tools.html"
+UPSTREAM_CHECK_REGEX = "wireless_tools\.(?P<pver>(\d+)(\..*|))\.tar\.gz"
+
+S = "${WORKDIR}/wireless_tools.30"
+
+CFLAGS =+ "-I${S}"
+EXTRA_OEMAKE = "-e 'BUILD_SHARED=y' \
+ 'INSTALL_DIR=${D}${base_sbindir}' \
+ 'INSTALL_LIB=${D}${libdir}' \
+ 'INSTALL_INC=${D}${includedir}' \
+ 'INSTALL_MAN=${D}${mandir}'"
+
+do_compile() {
+ oe_runmake all libiw.a
+}
+
+do_install() {
+ oe_runmake PREFIX=${D} install-iwmulticall install-dynamic install-man install-hdr
+ install -d ${D}${sbindir}
+ install -m 0755 ifrename ${D}${sbindir}/ifrename
+}
+
+PACKAGES = "libiw libiw-dev libiw-doc ifrename-doc ifrename ${PN} ${PN}-doc ${PN}-dbg"
+
+FILES_libiw = "${libdir}/*.so.*"
+FILES_libiw-dev = "${libdir}/*.a ${libdir}/*.so ${includedir}"
+FILES_libiw-doc = "${mandir}/man7"
+FILES_ifrename = "${sbindir}/ifrename"
+FILES_ifrename-doc = "${mandir}/man8/ifrename.8 ${mandir}/man5/iftab.5"
+FILES_${PN} = "${bindir} ${sbindir}/iw* ${base_sbindir} ${base_bindir} ${sysconfdir}/network"
+FILES_${PN}-doc = "${mandir}"
diff --git a/recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch b/recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch
new file mode 100644
index 0000000..a1f97b3
--- /dev/null
+++ b/recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch
@@ -0,0 +1,136 @@
+For xwayland gdk/gdkx.h does not work.
+Remove the more elaborate gf_display_get_workarea function and use only
+the fallback.
+--- ./src/working-area.c.orig 2016-02-20 22:38:31.000000000 +0000
++++ ./src/working-area.c 2020-01-07 13:37:47.023817524 +0000
+@@ -23,126 +23,11 @@
+ */
+
+ # include <gdk/gdk.h>
+-# include <gdk/gdkx.h>
+-# include <X11/Xlib.h>
+-# include <X11/Xutil.h>
+-# include <X11/Xatom.h>
+-
+-void get_working_area(GdkScreen* screen, GdkRectangle *rect);
+-
+-static gboolean gf_display_get_workarea(GdkScreen* g_screen, GdkRectangle *rect) {
+- Atom xa_desktops, xa_current, xa_workarea, xa_type;
+- Display *x_display;
+- Window x_root;
+- guint32 desktops = 0, current = 0;
+- gulong *workareas, len, fill;
+- guchar *data;
+- gint format;
+-
+- GdkDisplay *g_display;
+- Screen *x_screen;
+-
+- /* get the gdk display */
+- g_display = gdk_display_get_default();
+- if(!g_display)
+- return FALSE;
+-
+- /* get the x display from the gdk display */
+- x_display = gdk_x11_display_get_xdisplay(g_display);
+- if(!x_display)
+- return FALSE;
+-
+- /* get the x screen from the gdk screen */
+- x_screen = gdk_x11_screen_get_xscreen(g_screen);
+- if(!x_screen)
+- return FALSE;
+-
+- /* get the root window from the screen */
+- x_root = XRootWindowOfScreen(x_screen);
+-
+- /* find the _NET_NUMBER_OF_DESKTOPS atom */
+- xa_desktops = XInternAtom(x_display, "_NET_NUMBER_OF_DESKTOPS", True);
+- if(xa_desktops == None)
+- return FALSE;
+-
+- /* get the number of desktops */
+- if(XGetWindowProperty(x_display, x_root, xa_desktops, 0, 1, False,
+- XA_CARDINAL, &xa_type, &format, &len, &fill,
+- &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- if(!data)
+- return FALSE;
+-
+- desktops = *(guint32 *)data;
+- XFree(data);
+-
+- /* find the _NET_CURRENT_DESKTOP atom */
+- xa_current = XInternAtom(x_display, "_NET_CURRENT_DESKTOP", True);
+- if(xa_current == None)
+- return FALSE;
+-
+- /* get the current desktop */
+- if(XGetWindowProperty(x_display, x_root, xa_current, 0, 1, False,
+- XA_CARDINAL, &xa_type, &format, &len, &fill,
+- &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- if(!data)
+- return FALSE;
+-
+- current = *(guint32 *)data;
+- XFree(data);
+-
+- /* find the _NET_WORKAREA atom */
+- xa_workarea = XInternAtom(x_display, "_NET_WORKAREA", True);
+- if(xa_workarea == None)
+- return FALSE;
+-
+- if(XGetWindowProperty(x_display, x_root, xa_workarea, 0, (glong)(4 * 32),
+- False, AnyPropertyType, &xa_type, &format, &len,
+- &fill, &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- /* make sure the type and format are good */
+- if(xa_type == None || format == 0)
+- return FALSE;
+-
+- /* make sure we don't have any leftovers */
+- if(fill)
+- return FALSE;
+-
+- /* make sure len divides evenly by 4 */
+- if(len % 4)
+- return FALSE;
+-
+- /* it's good, lets use it */
+- workareas = (gulong *)(guint32 *)data;
+-
+- rect->x = (guint32)workareas[current * 4];
+- rect->y = (guint32)workareas[current * 4 + 1];
+- rect->width = (guint32)workareas[current * 4 + 2];
+- rect->height = (guint32)workareas[current * 4 + 3];
+-
+- /* clean up our memory */
+- XFree(data);
+-
+- return TRUE;
+-}
+
+ void get_working_area(GdkScreen* screen, GdkRectangle *rect)
+ {
+- if( !gf_display_get_workarea(screen, rect) )
+- {
+- rect->x = 0;
+- rect->y = 0;
+- rect->width = gdk_screen_width();
+- rect->height = gdk_screen_height();
+- }
++ rect->x = 0;
++ rect->y = 0;
++ rect->width = gdk_screen_width();
++ rect->height = gdk_screen_height();
+ }
diff --git a/recipes-lxde/gpicview/gpicview_0.2.5.bb b/recipes-lxde/gpicview/gpicview_0.2.5.bb
index c6061b2..cee82b7 100644
--- a/recipes-lxde/gpicview/gpicview_0.2.5.bb
+++ b/recipes-lxde/gpicview/gpicview_0.2.5.bb
@@ -5,10 +5,13 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-DEPENDS = "glib-2.0-native gtk+ intltool-native jpeg"
+DEPENDS = "glib-2.0-native intltool-native jpeg"
RDEPENDS_${PN} = "adwaita-icon-theme"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz"
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz \
+ file://remove-gdk-x11.patch \
+"
SRC_URI[md5sum] = "26be9b0c5a234f1afe7d83d02a4a33f4"
SRC_URI[sha256sum] = "38466058e53702450e5899193c4b264339959b563dd5cd81f6f690de32d82942"
@@ -16,6 +19,6 @@ PACKAGECONFIG ?= "gtk3"
PACKAGECONFIG[gtk2] = ",,gtk+"
PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
-inherit autotools gettext pkgconfig
+inherit autotools gettext mime-xdg pkgconfig
FILES_${PN} += "${datadir}/icons/*"
diff --git a/recipes-lxde/images/core-image-lxde.bb b/recipes-lxde/images/core-image-lxde.bb
new file mode 100644
index 0000000..3356f8c
--- /dev/null
+++ b/recipes-lxde/images/core-image-lxde.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Image with the LXDE desktop environment"
+export IMAGE_BASENAME = "core-image-lxde"
+
+LICENSE = "MIT"
+
+# Most LXDE components don't even compile without native X11 support,
+# (gdk-x11), so make this fail early if x11 is provided by XWAYLAND.
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+CONFLICT_DISTRO_FEATURES = "wayland"
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+IMAGE_LINGUAS = " "
+
+IMAGE_INSTALL += " \
+ packagegroup-core-boot \
+ packagegroup-core-x11 \
+ packagegroup-lxde-extended \
+ kernel-modules \
+ \
+ lxdm \
+ \
+ openbox \
+ openbox-theme-clearlooks \
+ openbox-theme-onyx \
+ obconf \
+ hicolor-icon-theme \
+"
+
+IMAGE_DEV_MANAGER = "udev"
+IMAGE_INIT_MANAGER = "systemd"
+IMAGE_INITSCRIPTS = " "
+IMAGE_LOGIN_MANAGER = "busybox shadow"
+
+inherit core-image
diff --git a/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb b/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb
index e44b1d1..762d0bf 100644
--- a/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb
+++ b/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb
@@ -6,9 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "glib-2.0-native intltool-native libcroco librsvg lxappearance menu-cache openbox"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxappearance-obconf-${PV}.tar.xz"
-# only needed for gtk3, applied unconditionally thow
-SRC_URI += "file://window_border_broken_with_gtk3.patch"
+# patch only needed for gtk3, applied unconditionally though
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/lxde/lxappearance-obconf-${PV}.tar.xz \
+ file://window_border_broken_with_gtk3.patch \
+"
SRC_URI[md5sum] = "ae0076d489aa786f5d573f7ff592a4ab"
SRC_URI[sha256sum] = "3150b33b4b7beb71c1803aee2be21c94767d73b70dfc8d2bcaafe2650ea83149"
diff --git a/recipes-lxde/lxde-common/lxde-common_0.99.2.bb b/recipes-lxde/lxde-common/lxde-common_0.99.2.bb
index 523e166..a3d76c7 100644
--- a/recipes-lxde/lxde-common/lxde-common_0.99.2.bb
+++ b/recipes-lxde/lxde-common/lxde-common_0.99.2.bb
@@ -19,7 +19,6 @@ inherit autotools gettext update-alternatives
FILES_${PN} += "${datadir}/lxde/ ${datadir}/lxpanel ${datadir}/xsessions"
-ALTERNATIVE_${PN} = "x-window-manager"
-ALTERNATIVE_LINK_NAME[x-window-manager] = "${bindir}/x-window-manager"
-ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/startlxde"
-ALTERNATIVE_PRIORITY[x-window-manager] = "15"
+ALTERNATIVE_${PN} = "x-session-manager"
+ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/startlxde"
+ALTERNATIVE_PRIORITY[x-session-manager] = "110"
diff --git a/recipes-lxde/lxmenu-data/lxmenu-data/lxmenu-replace_am_glib_gnu_gettext.patch b/recipes-lxde/lxmenu-data/lxmenu-data/lxmenu-replace_am_glib_gnu_gettext.patch
index 8998aca..ee05afc 100644
--- a/recipes-lxde/lxmenu-data/lxmenu-data/lxmenu-replace_am_glib_gnu_gettext.patch
+++ b/recipes-lxde/lxmenu-data/lxmenu-data/lxmenu-replace_am_glib_gnu_gettext.patch
@@ -1,8 +1,18 @@
---- lxmenu-data-0.1.2/configure.in~ 2011-07-23 22:05:34.000000000 +0200
-+++ lxmenu-data-0.1.2/configure.ac 2014-04-30 18:20:09.985465810 +0200
-@@ -6,7 +6,10 @@
- AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of default gettext domain])
- AC_SUBST(GETTEXT_PACKAGE)
+From a13f91a5451f614441f518f772575d706e1fd04d Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Mon, 9 Jun 2014 12:01:35 +0200
+
+---
+ configure.ac | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ba670a7..449fe6b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,7 +16,10 @@ do
+ echo $lang >> $srcdir/po/LINGUAS
+ done
-AM_GLIB_GNU_GETTEXT
+#AM_GLIB_GNU_GETTEXT
diff --git a/recipes-lxde/lxrandr/lxrandr/0001-lxrandr.c-improve-xrandr-output-parser-to-cope-with-.patch b/recipes-lxde/lxrandr/lxrandr/0001-lxrandr.c-improve-xrandr-output-parser-to-cope-with-.patch
index 04f34a2..2f4e3d4 100644
--- a/recipes-lxde/lxrandr/lxrandr/0001-lxrandr.c-improve-xrandr-output-parser-to-cope-with-.patch
+++ b/recipes-lxde/lxrandr/lxrandr/0001-lxrandr.c-improve-xrandr-output-parser-to-cope-with-.patch
@@ -1,4 +1,4 @@
-From 81c49c9cb5180894fee6adab99d4d2e982d2a293 Mon Sep 17 00:00:00 2001
+From 184a6e9dad1adc67d6d3d8e4682e987aee644194 Mon Sep 17 00:00:00 2001
From: Max Krummenacher <max.krummenacher@toradex.com>
Date: Sat, 25 Mar 2017 17:51:53 +0100
Subject: [PATCH] lxrandr.c: improve xrandr output parser to cope with i.mx 6
@@ -31,21 +31,21 @@ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/src/lxrandr.c b/src/lxrandr.c
-index 33e02b2..b8c266d 100644
+index 0d46e9c..c40d446 100644
--- a/src/lxrandr.c
+++ b/src/lxrandr.c
@@ -118,8 +118,8 @@ static gboolean get_xrandr_info()
return FALSE;
}
-- regex = g_regex_new( "\n([-a-zA-Z]+[-0-9]*) +connected ([^(\n ]*)[^\n]*"
+- regex = g_regex_new( "\n([-\\.a-zA-Z]+[-\\.0-9]*) +connected ([^(\n ]*)[^\n]*"
- "((\n +[0-9]+x[0-9]+[^\n]+)+)",
-+ regex = g_regex_new( "\n([ -a-zA-Z0-9]+[-0-9]*) +connected [ a-zA-Z]*([^(\n ]*)[^\n]*"
++ regex = g_regex_new( "\n([ -\\.a-zA-Z0-9]+[-\\.0-9]*) +connected [ a-zA-Z]*([^(\n ]*)[^\n]*"
+ "((\n +[SUV:]*[0-9]+x[0-9]+.*[^\n]+)+)",
0, 0, NULL );
if( g_regex_match( regex, output, 0, &match ) )
{
-@@ -343,8 +343,9 @@ static GString* get_command_xrandr_info()
+@@ -349,8 +349,9 @@ static GString* get_command_xrandr_info()
for( l = monitors; l; l = l->next )
{
Monitor* m = (Monitor*)l->data;
@@ -56,7 +56,7 @@ index 33e02b2..b8c266d 100644
// if the monitor is turned on
if (m->try_mode >= 0)
-@@ -403,7 +404,9 @@ static GString* get_command_xrandr_info()
+@@ -409,7 +410,9 @@ static GString* get_command_xrandr_info()
case PLACEMENT_DEFAULT:
g_string_append(cmd, " --same-as ");
}
@@ -66,7 +66,7 @@ index 33e02b2..b8c266d 100644
}
else if (l != monitors)
{
-@@ -426,7 +429,9 @@ static GString* get_command_xrandr_info()
+@@ -432,7 +435,9 @@ static GString* get_command_xrandr_info()
case PLACEMENT_DEFAULT:
g_string_append(cmd, " --same-as ");
}
@@ -77,5 +77,5 @@ index 33e02b2..b8c266d 100644
/* g_string_append( cmd, "" ); */
--
-2.6.6
+2.20.1
diff --git a/recipes-lxde/lxrandr/lxrandr_0.3.1.bb b/recipes-lxde/lxrandr/lxrandr_0.3.2.bb
index d1ec999..9c2aa63 100644
--- a/recipes-lxde/lxrandr/lxrandr_0.3.1.bb
+++ b/recipes-lxde/lxrandr/lxrandr_0.3.2.bb
@@ -12,8 +12,8 @@ SRC_URI = " \
file://0001-lxrandr.c-improve-xrandr-output-parser-to-cope-with-.patch \
"
-SRC_URI[md5sum] = "b327938f18a4baac85c4707f927d606e"
-SRC_URI[sha256sum] = "6d98338485a90d9e47f6d08184df77ca0d9715517f8a45a914e861750589184e"
+SRC_URI[md5sum] = "5101ab29d87fb2b56a5ec5bc8bc3f258"
+SRC_URI[sha256sum] = "8b5edfc9718061bc161fe51d388697cbaa819d6f8013ed24ba22f438e0dbc312"
PACKAGECONFIG ?= "gtk3"
PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
diff --git a/recipes-lxde/lxsession/lxsession_0.5.3.bb b/recipes-lxde/lxsession/lxsession_0.5.4.bb
index 07c0131..965f71d 100644
--- a/recipes-lxde/lxsession/lxsession_0.5.3.bb
+++ b/recipes-lxde/lxsession/lxsession_0.5.4.bb
@@ -2,19 +2,19 @@ SUMMARY = "LXDE session manager"
HOMEPAGE = "http://lxde.sf.net/"
SECTION = "x11"
-PR = "r3"
-
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=a76102f7f48780284bee49e6edaeb5a9"
-DEPENDS = "dbus dbus-glib glib-2.0 intltool-native libgee libunique virtual/libx11 lxde-common polkit vala-native xproto"
+DEPENDS = "dbus dbus-glib glib-2.0 intltool-native libgee libunique virtual/libx11 lxde-common polkit vala-native xorgproto"
RDEPENDS_${PN} = "upower dbus-x11"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxsession-${PV}.tar.xz"
-SRC_URI += "file://0001-replace-use-of-UniqueApp-with-GtkApplication.patch"
-SRC_URI += "file://0002-GTK-3-GtkObject-no-longer-exists.patch"
-SRC_URI[md5sum] = "823c50e6d0e4ce15a23a42e8f8bf4221"
-SRC_URI[sha256sum] = "90bf42a45421f45f2c745d60f2c730176e1472642451c06c2ab07dcebdaf1fa8"
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/lxde/lxsession-${PV}.tar.xz \
+ file://0001-replace-use-of-UniqueApp-with-GtkApplication.patch \
+ file://0002-GTK-3-GtkObject-no-longer-exists.patch \
+"
+SRC_URI[md5sum] = "e255aaf3c2a8e49812e3477fb3f099b0"
+SRC_URI[sha256sum] = "252f84c80fd3713a506cc8d8ac9773175712d47b031cacc08c8027622ce7ec5d"
PACKAGECONFIG ?= "gtk3"
PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
@@ -24,6 +24,6 @@ python __anonymous () {
d.setVar("DEPENDS", "%s gtk+" % depends)
}
-inherit autotools pkgconfig gettext gobject-introspection
+inherit autotools pkgconfig gettext
FILES_${PN} += "${datadir}/lxsession"
diff --git a/recipes-lxde/lxtask/lxtask_0.1.8.bb b/recipes-lxde/lxtask/lxtask_0.1.10.bb
index 26da2e8..fa30ec3 100644
--- a/recipes-lxde/lxtask/lxtask_0.1.8.bb
+++ b/recipes-lxde/lxtask/lxtask_0.1.10.bb
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "glib-2.0 glib-2.0-native intltool-native virtual/libintl"
SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxtask-${PV}.tar.xz"
-SRC_URI[md5sum] = "dd4f423dda192cb50618c6b1e76ec6b7"
-SRC_URI[sha256sum] = "dfb443805f72857b5ad711d4bb862a9cd3db0cd2df16d0c24f23ed679b0bef40"
+SRC_URI[md5sum] = "27b5258847afc237a5b89666e7a8b45b"
+SRC_URI[sha256sum] = "2216df9bc4bb2d80733e788966512ac58c421e0a0a1ff85210f34a29d1eb4e2c"
PACKAGECONFIG ?= "gtk3"
PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
diff --git a/recipes-lxde/lxterminal/lxterminal_0.3.1.bb b/recipes-lxde/lxterminal/lxterminal_0.3.2.bb
index 8d14ed4..5311ae8 100644
--- a/recipes-lxde/lxterminal/lxterminal_0.3.1.bb
+++ b/recipes-lxde/lxterminal/lxterminal_0.3.2.bb
@@ -10,8 +10,8 @@ SRC_URI = " \
${SOURCEFORGE_MIRROR}/lxde/lxterminal-${PV}.tar.xz \
file://0002-man-Makefile.am-don-t-error-out-on-missing-man-depen.patch \
"
-SRC_URI[md5sum] = "91febe1ec15297844333cb70f237b4b7"
-SRC_URI[sha256sum] = "cd8df387c2dd40e03b48caacf700820f9421b421954a0ed56395f505411d2c4b"
+SRC_URI[md5sum] = "62e57c3aafb831505cc1638b2b737cc9"
+SRC_URI[sha256sum] = "3166b18493a8e55811b02aa0de825cbbea65e2b628e69006c1a65b98e1bb4484"
EXTRA_OECONF += "--enable-gtk3 --enable-man"
diff --git a/recipes-lxde/obconf/obconf_2.0.4+git.bb b/recipes-lxde/obconf/obconf_2.0.4+git.bb
index c23d7d8..5ce7d3d 100644
--- a/recipes-lxde/obconf/obconf_2.0.4+git.bb
+++ b/recipes-lxde/obconf/obconf_2.0.4+git.bb
@@ -2,12 +2,12 @@ SUMMARY = "Tool for configuring the Openbox window manager"
HOMEPAGE = "http://openbox.org/wiki/ObConf:About"
SECTION = "x11"
-SRCREV = "fa924b595e37f1b13ba4c2e64c367b92bbd3c771"
+SRCREV = "63ec47c5e295ad4f09d1df6d92afb7e10c3fec39"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-DEPENDS = "gtk+ glib-2.0 libglade startup-notification openbox"
+DEPENDS = "gtk+3 glib-2.0 startup-notification openbox"
MIRRORS_prepend () {
git://git.openbox.org/dana/obconf git://github.com/danakj/obconf.git
@@ -20,7 +20,7 @@ S = "${WORKDIR}/git"
FILES_${PN} += "${datadir}/mime ${datadir}/mimelnk"
-inherit autotools-brokensep pkgconfig gettext mime
+inherit autotools-brokensep pkgconfig gettext mime mime-xdg
do_configure_prepend () {
autopoint --force || bbfatal "autopoint failed"
diff --git a/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb b/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb
index 20427eb..f685347 100644
--- a/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb
+++ b/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb
@@ -11,6 +11,7 @@ RDEPENDS_${PN} = "\
RRECOMMENDS_${PN} = " \
gpicview \
+ l3afpad \
lxhotkey \
lxlauncher \
lxinput \