summaryrefslogtreecommitdiff
path: root/recipes-core/fs-init
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-07-26 20:24:02 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 11:09:16 +0200
commit80d1028db9a00f89285680694947e1b70ffa81b2 (patch)
treecffc8a1ee12328474f403bb1fa9d9a6d4bac7f5b /recipes-core/fs-init
parent266e53b28f4365e537c8727fc0c554cefa66dd82 (diff)
systemd: adapt to new systemd handling
with the move from meta-openembedded to oe-core some things have changed, e.g. the config files have to explicitly installed
Diffstat (limited to 'recipes-core/fs-init')
-rw-r--r--recipes-core/fs-init/fs-init.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-core/fs-init/fs-init.bb b/recipes-core/fs-init/fs-init.bb
index b2b61a8..1a06a7e 100644
--- a/recipes-core/fs-init/fs-init.bb
+++ b/recipes-core/fs-init/fs-init.bb
@@ -16,6 +16,9 @@ do_compile () {
do_install () {
install -d ${D}/${sbindir}
install -m 0755 ${WORKDIR}/*.sh ${D}/${sbindir}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/resizefs.service ${D}${systemd_unitdir}/system
}
NATIVE_SYSTEMD_SUPPORT = "1"