summaryrefslogtreecommitdiff
path: root/recipes-bsp/gpio-export
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/gpio-export')
-rw-r--r--recipes-bsp/gpio-export/files/COPYING5
-rw-r--r--recipes-bsp/gpio-export/files/apalis-imx6/gpio-export.sh51
-rw-r--r--recipes-bsp/gpio-export/files/gpio-export.service12
-rw-r--r--recipes-bsp/gpio-export/files/gpio-export.sh4
-rw-r--r--recipes-bsp/gpio-export/gpio-export_1.0.bb26
5 files changed, 0 insertions, 98 deletions
diff --git a/recipes-bsp/gpio-export/files/COPYING b/recipes-bsp/gpio-export/files/COPYING
deleted file mode 100644
index 040e990..0000000
--- a/recipes-bsp/gpio-export/files/COPYING
+++ /dev/null
@@ -1,5 +0,0 @@
-This piece is software is provided by Toradex AG as sample code.
-There is no warranty for the program.
-Toradex AG put this program in public domain, uncopyrighted.
-
-Renens, Swizterland, 2008-10-23
diff --git a/recipes-bsp/gpio-export/files/apalis-imx6/gpio-export.sh b/recipes-bsp/gpio-export/files/apalis-imx6/gpio-export.sh
deleted file mode 100644
index ec259a6..0000000
--- a/recipes-bsp/gpio-export/files/apalis-imx6/gpio-export.sh
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/sh
-#export gpios to userspace
-
-case "$1" in
- start)
- CTRL=/sys/class/gpio/export
- ;;
-
- stop)
- CTRL=/sys/class/gpio/unexport
- ;;
-
- *)
- echo "usage: '$0 start' '$0 stop'"
- exit 1
- ;;
-esac
-
-#Apalis GPIO - i.MX6 Ball name - GPIO#
-
-#GPIO1 NAND_DATA04 36
-#used by OV5640 kernel module
-#echo 36 > $CTRL
-#cat /sys/class/gpio/gpio36/value
-#echo low > /sys/class/gpio/gpio36/direction
-#echo 1 > /sys/class/gpio/gpio36/value
-
-#GPIO2 NAND_DATA05 37
-#used by OV5640 kernel module
-#echo 37 > $CTRL
-
-#GPIO3 NAND_DATA06 38
-echo 38 > $CTRL
-
-#GPIO4 NAND_DATA07 39
-echo 39 > $CTRL
-
-#GPIO5 NAND_READY 170
-#used by optional fusion_F0710A kernel module
-#echo 170 > $CTRL
-
-#GPIO6 NAND_WP_B 169
-#used by optional fusion_F0710A kernel module
-#echo 169 > $CTRL
-
-#GPIO7 GPIO02 2
-#used by PCIe for reset of switch on the Apalis Evaluation Board
-#echo 2 > $CTRL
-
-#GPIO8 GPIO06 6
-echo 6 > $CTRL
diff --git a/recipes-bsp/gpio-export/files/gpio-export.service b/recipes-bsp/gpio-export/files/gpio-export.service
deleted file mode 100644
index 2dba716..0000000
--- a/recipes-bsp/gpio-export/files/gpio-export.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Export GPIOs to user space
-DefaultDependencies=no
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/usr/bin/gpio-export.sh start
-ExecStop=/usr/bin/gpio-export.sh stop
-
-[Install]
-WantedBy=basic.target
diff --git a/recipes-bsp/gpio-export/files/gpio-export.sh b/recipes-bsp/gpio-export/files/gpio-export.sh
deleted file mode 100644
index 6a477c6..0000000
--- a/recipes-bsp/gpio-export/files/gpio-export.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-#empty placeholder for machines not using that feature
-
-:
diff --git a/recipes-bsp/gpio-export/gpio-export_1.0.bb b/recipes-bsp/gpio-export/gpio-export_1.0.bb
deleted file mode 100644
index 392382a..0000000
--- a/recipes-bsp/gpio-export/gpio-export_1.0.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "Scripts and systemd service file to export unused GPIO to Userspace"
-LICENSE = "PD"
-PR = "r2"
-
-inherit systemd
-
-SRC_URI = " \
- file://gpio-export.sh \
- file://gpio-export.service \
- file://COPYING \
-"
-
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
-
-do_install () {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/*.sh ${D}/${bindir}
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/gpio-export.service ${D}${systemd_unitdir}/system
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "gpio-export.service"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"