summaryrefslogtreecommitdiff
path: root/recipes-core/set-hostname/set-hostname_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/set-hostname/set-hostname_1.0.bb')
-rw-r--r--recipes-core/set-hostname/set-hostname_1.0.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-core/set-hostname/set-hostname_1.0.bb b/recipes-core/set-hostname/set-hostname_1.0.bb
deleted file mode 100644
index 15fa66b..0000000
--- a/recipes-core/set-hostname/set-hostname_1.0.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit systemd
-
-SRC_URI += " \
- file://sethostname \
- file://set-hostname.service \
-"
-
-FILES_${PN} = " \
- ${bindir} \
- ${systemd_system_unitdir} \
-"
-
-SYSTEMD_SERVICE_${PN} = " \
- set-hostname.service \
-"
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/sethostname ${D}${bindir}
- sed -i "s/@@MACHINE@@/${MACHINE}/g" ${D}${bindir}/sethostname
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/set-hostname.service ${D}${systemd_system_unitdir}
- fi
-}