summaryrefslogtreecommitdiff
path: root/recipes-support/tdx-info/tdx-info_0.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/tdx-info/tdx-info_0.1.1.bb')
-rw-r--r--recipes-support/tdx-info/tdx-info_0.1.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-support/tdx-info/tdx-info_0.1.1.bb b/recipes-support/tdx-info/tdx-info_0.1.1.bb
new file mode 100644
index 0000000..61ee751
--- /dev/null
+++ b/recipes-support/tdx-info/tdx-info_0.1.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Script to get useful information about Toradex Hardware."
+DESCRIPTION = "This script can be used by Toradex customers in userspace to grab information from the module and share it with Toradex Support Team"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c38c9404df9658111a87d5090719fb44"
+
+SRC_URI = "git://github.com/toradex/tdx-info;protocol=https;branch=v${PV}"
+SRCREV = "80840350f00965e9862a354a1bd870954f8af18e"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/tdx-info ${D}${bindir}
+}