summaryrefslogtreecommitdiff
path: root/recipes-images/images/packagegroup-tdx-graphical.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 10:05:53 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 14:04:06 +0200
commit3266310497aba5295298903f2451b2692889ccd6 (patch)
treed44453b6c17e0e039d963049b163db2206f3c547 /recipes-images/images/packagegroup-tdx-graphical.bb
parent1e67bf9e77b5d4458642c81cfefaa83b25ae4f9b (diff)
images: replace soc overrides to also include use-mainline-bsp
With use-mainline-bsp the SoC overrides mx6/mx6q/mx6ull... are filtered out of the overrides. Replace them with the specific machine name if the override should also be active in the use-mainline-bsp case for that machine. Related-to: ELB-2805 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 31a39f3502bb0b7c3012a2adc61442d3d2547557)
Diffstat (limited to 'recipes-images/images/packagegroup-tdx-graphical.bb')
-rw-r--r--recipes-images/images/packagegroup-tdx-graphical.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-images/images/packagegroup-tdx-graphical.bb b/recipes-images/images/packagegroup-tdx-graphical.bb
index fbff118..1054cb2 100644
--- a/recipes-images/images/packagegroup-tdx-graphical.bb
+++ b/recipes-images/images/packagegroup-tdx-graphical.bb
@@ -67,15 +67,17 @@ IMAGE_INSTALL_OPENCL_IMX = " \
RRECOMMENDS_packagegroup-gpu-tdx-graphical = " \
glmark2 \
"
-IMAGE_INSTALL_MX6QDL = " \
+IMAGE_INSTALL_GPU_MX6QDL = " \
packagegroup-fsl-gpu-libs \
"
-RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx6dl = " ${IMAGE_INSTALL_MX6QDL}"
+RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx6dl = " \
+ ${IMAGE_INSTALL_GPU_MX6QDL} \
+"
RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx6q = " \
- ${IMAGE_INSTALL_MX6QDL} \
+ ${IMAGE_INSTALL_GPU_MX6QDL} \
${IMAGE_INSTALL_OPENCL_IMX} \
"
-RRECOMMENDS_packagegroup-gpu-tdx-graphical_mx6ull = ""
+RRECOMMENDS_packagegroup-gpu-tdx-graphical_colibri-imx6ull = ""
RRECOMMENDS_packagegroup-gpu-tdx-graphical_append_mx8 = " \
tinycompress \
libvdk-imx \