summaryrefslogtreecommitdiff
path: root/recipes-qt/qedit/qedit_2.8.2.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-01-01 16:06:32 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-03-22 09:19:20 +0100
commit30cff779fcc76203f0694cf517b7d96d1f7f3603 (patch)
treed39cd85c652f494b6a787787bfe999ea666b204f /recipes-qt/qedit/qedit_2.8.2.bb
parent9e5f7d94a94e524606912d0f2b0331c290ae2229 (diff)
qedit: add a qt5 text editor
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-qt/qedit/qedit_2.8.2.bb')
-rw-r--r--recipes-qt/qedit/qedit_2.8.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-qt/qedit/qedit_2.8.2.bb b/recipes-qt/qedit/qedit_2.8.2.bb
new file mode 100644
index 0000000..112a8c0
--- /dev/null
+++ b/recipes-qt/qedit/qedit_2.8.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "QEdit Text Editor"
+HOMEPAGE = "http://hugo.pereira.free.fr/software/index.php?page=package&package_list=software_list_qt&package=qedit&full=0"
+SECTION = "x11"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=81bcece21748c91ba9992349a91ec11d"
+
+DEPENDS = "qtbase qtx11extras"
+
+inherit cmake_qt5
+
+SRC_URI = " \
+ http://hugo.pereira.free.fr/software/tgz/qedit-2.8.2.tar.gz \
+ file://qedit.desktop \
+ file://0001-Options.cpp-provide-default-for-SIDE_PANEL_TOOLBAR_T.patch \
+"
+SRC_URI[md5sum] = "7cca177ea042b230678ba0bb36269665"
+SRC_URI[sha256sum] = "cc0686927ec8ffe44527f682b3a8d9585f753d643543fae061cb023a3b71ddb0"
+
+EXTRA_OECMAKE = "-DUSE_QT5=ON"
+#export EXTRA_OECMAKE = "-DCMAKE_INSTALL_PREFIX=/usr"
+do_configure() {
+ # Ensure we get the cmake configure and not qmake
+ cmake_do_configure
+}
+
+do_install_append () {
+ install -d ${D}/${datadir}/applications
+ install -m 755 ${WORKDIR}/qedit.desktop ${D}/${datadir}/applications/
+}
+
+FILES_${PN} += ""
+FILES_${PN}-dev += ""