summaryrefslogtreecommitdiff
path: root/qt5-layer/recipes-qt/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'qt5-layer/recipes-qt/qt5')
-rw-r--r--qt5-layer/recipes-qt/qt5/packagegroup-qt5.bb2
-rw-r--r--qt5-layer/recipes-qt/qt5/qt3d_%.bbappend8
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb25
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init43
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service10
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase/qt5-fb.sh2
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase/qt5-wayland.sh3
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend26
8 files changed, 32 insertions, 87 deletions
diff --git a/qt5-layer/recipes-qt/qt5/packagegroup-qt5.bb b/qt5-layer/recipes-qt/qt5/packagegroup-qt5.bb
index 32700ad..222e970 100644
--- a/qt5-layer/recipes-qt/qt5/packagegroup-qt5.bb
+++ b/qt5-layer/recipes-qt/qt5/packagegroup-qt5.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
inherit packagegroup
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
qtbase \
qtbase-tools \
qtmultimedia \
diff --git a/qt5-layer/recipes-qt/qt5/qt3d_%.bbappend b/qt5-layer/recipes-qt/qt5/qt3d_%.bbappend
index 85d7eab..eb597ea 100644
--- a/qt5-layer/recipes-qt/qt5/qt3d_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qt3d_%.bbappend
@@ -1,13 +1,13 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/qt3d:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/qt3d:"
# qt3d links against the opengl flavours we configured qtbase for, so
# depend on them here
DEPENDS_GLES = ""
-DEPENDS_GLES_imxpxp += "virtual/libgles2 virtual/egl"
+DEPENDS_GLES:imxpxp += "virtual/libgles2 virtual/egl"
DEPENDS_GLES_imgpu3d += "virtual/libgles2 virtual/egl"
-DEPENDS_GLES_use-mainline-bsp += "virtual/libgles2 virtual/egl"
+DEPENDS_GLES:upstream += "virtual/libgles2 virtual/egl"
-DEPENDS_class-target += " ${DEPENDS_GLES}"
+DEPENDS:class-target += " ${DEPENDS_GLES}"
# Fix race condition
SRC_URI += "file://0001-qt3d-do-not-set-resources_big.patch"
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
deleted file mode 100644
index f6ba46d..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-SECTION = "x11/libs"
-SUMMARY = "systemd qtapplication autostart"
-# The license is meant for this recipe and the files it installs.
-# RNDIS is part of the kernel, udhcpd is part of busybox
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://qt5-x11-demo.service \
- file://qt5-x11-demo-init \
-"
-
-do_install () {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/qt5-x11-demo-init ${D}/${bindir}
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/qt5-x11-demo.service ${D}${systemd_unitdir}/system
-}
-
-NATIVE_SYSTEMD_SUPPORT = "1"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "qt5-x11-demo.service"
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init
deleted file mode 100644
index 76922ec..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-
-set -e
-
-cd /usr/share/qtsmarthome-1.0
-QTAPP="smarthome"
-QTAPPSTART="./${QTAPP} > /var/log/Xsession.log 2>&1"
-
-case "$1" in
- start)
- echo "Starting ${QTAPP}"
- if [ -f /etc/profile.d/tslib.sh ]; then
- source /etc/profile.d/tslib.sh
- fi
- if [ -e "$TSLIB_TSDEVICE" ]; then
- if [ ! -f /etc/pointercal ]; then
- /usr/bin/ts_calibrate
- fi
- else
- if [ -e "/usr/bin/xinput_calibrator_once.sh" ]; then
- xinput_calibrator_once.sh
- fi
- fi
- Xorg &
- export DISPLAY=:0
- eval $QTAPPSTART &
- ;;
- stop)
- echo "Stopping ${QTAPP}"
- killall $QTAPP
- killall Xorg
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 { start | stop | restart }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service
deleted file mode 100644
index 053f273..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=start X and a qt application
-
-[Service]
-Type=forking
-ExecStart=/usr/bin/qt5-x11-demo-init start
-ExecStop=/usr/bin/qt5-x11-demo-init stop
-
-[Install]
-WantedBy=graphical.target
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/qt5-fb.sh b/qt5-layer/recipes-qt/qt5/qtbase/qt5-fb.sh
new file mode 100644
index 0000000..34fa033
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase/qt5-fb.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+export QT_QPA_PLATFORM=eglfs
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/qt5-wayland.sh b/qt5-layer/recipes-qt/qt5/qtbase/qt5-wayland.sh
new file mode 100644
index 0000000..886d7c3
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qtbase/qt5-wayland.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+export QT_QPA_PLATFORM=wayland-egl
+
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 0b6f29b..83eeb1a 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -7,13 +7,31 @@ PACKAGECONFIG_EXAMPLES ?= "examples"
# | /build/krm/oe-core_V2.6/build/out-glibc/work/armv7at2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.1+gitAUTOINC+5afc431323-r0/git/src/widgets/styles/qgtkstyle.cpp:3636:74: error: 'QAccessible' has not been declared
# | } else if (QStyleHelper::isInstanceOf(groupBox->styleObject, QAccessible::Grouping)) {
-PACKAGECONFIG_append = " accessibility"
-PACKAGECONFIG_append = " sql-sqlite"
+PACKAGECONFIG:append = " accessibility"
+PACKAGECONFIG:append = " sql-sqlite"
-PACKAGECONFIG_FONTS_append = " fontconfig"
+PACKAGECONFIG_FONTS:append = " fontconfig"
#qtbase must be configured with icu for qtwebkit
-PACKAGECONFIG_append = " \
+PACKAGECONFIG:append = " \
icu \
${PACKAGECONFIG_EXAMPLES} \
"
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+IMX_BACKEND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
+ 'fb', d), d)}"
+
+SRC_URI:append = " \
+ file://qt5-${IMX_BACKEND}.sh \
+"
+
+do_install:append () {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${WORKDIR}/qt5-${IMX_BACKEND}.sh ${D}${sysconfdir}/profile.d/
+
+}
+
+FILES:${PN} += "${sysconfdir}/profile.d/qt5*.sh"