summaryrefslogtreecommitdiff
path: root/recipes-graphics/x-window-simple-app
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/x-window-simple-app')
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb9
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-simple-app.inc36
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-simple-app/set_have_touch.sh2
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-simple-app/x-window-manager.in6
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb9
5 files changed, 0 insertions, 62 deletions
diff --git a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
deleted file mode 100644
index 968c98e..0000000
--- a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-# set the following variable to your one and only application which should
-# be started
-
-INITIAL_APP_PKGS ?= "qtsmarthome"
-INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0"
-X_APPLICATION ?= "${INITIAL_PATH}/smarthome"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
-require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-simple-app.inc b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
deleted file mode 100644
index c9578ad..0000000
--- a/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
+++ /dev/null
@@ -1,36 +0,0 @@
-SECTION = "x11/libs"
-SUMMARY = "x11 application autostart"
-DESCRIPTION = \
-"This installs a /usr/bin/x-window-manager script. The script will start the \
-one and only application X_APPLICATION as the last step of the \
-xserver-nodm-init X initialization. \
-If the script ever returns, X will be killed."
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit allarch
-
-RDEPENDS_${PN} += "${INITIAL_APP_PKGS} xserver-nodm-init"
-
-S = "${WORKDIR}"
-
-SRC_URI = " \
- file://x-window-manager.in \
- file://set_have_touch.sh \
-"
-
-do_compile () {
- sed -e "s:@PATH@:${INITIAL_PATH}:" -e "s:@APP@:${X_APPLICATION}:" x-window-manager.in > x-window-manager
-}
-
-do_install () {
- install -d ${D}/${bindir} ${D}${sysconfdir}/X11/Xsession.d
- install -m 0755 ${S}/x-window-manager ${D}/${bindir}
- install -m 0644 ${S}/set_have_touch.sh ${D}/${sysconfdir}/X11/Xsession.d/29set_have_touch.sh
-}
-
-# make sure xinput_calibrator is only started once
-pkg_postinst_${PN}() {
- rm -f /etc/xdg/autostart/xinput_calibrator.desktop
-}
diff --git a/recipes-graphics/x-window-simple-app/x-window-simple-app/set_have_touch.sh b/recipes-graphics/x-window-simple-app/x-window-simple-app/set_have_touch.sh
deleted file mode 100644
index d4d49d5..0000000
--- a/recipes-graphics/x-window-simple-app/x-window-simple-app/set_have_touch.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-# force have touchscreen
-HAVE_TOUCHSCREEN=1
diff --git a/recipes-graphics/x-window-simple-app/x-window-simple-app/x-window-manager.in b/recipes-graphics/x-window-simple-app/x-window-simple-app/x-window-manager.in
deleted file mode 100644
index b3e0e8f..0000000
--- a/recipes-graphics/x-window-simple-app/x-window-simple-app/x-window-manager.in
+++ /dev/null
@@ -1,6 +0,0 @@
-RET=1
-while [ $RET -ne 0 ]; do
- cd @PATH@
- @APP@
- RET=$?
-done
diff --git a/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
deleted file mode 100644
index 302a0c7..0000000
--- a/recipes-graphics/x-window-simple-app/x-window-xterm_1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-# set the following variable to your one and only application which should
-# be started
-
-INITIAL_APP_PKGS ?= "xterm"
-INITIAL_PATH ?= ""
-X_APPLICATION ?= "/usr/bin/xterm"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
-require recipes-graphics/x-window-simple-app/x-window-simple-app.inc