summaryrefslogtreecommitdiff
path: root/recipes-images/images/tdx-reference-multimedia-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images/images/tdx-reference-multimedia-image.bb')
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb28
1 files changed, 17 insertions, 11 deletions
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 4061872..4299e81 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -8,38 +8,44 @@ inherit populate_sdk_qt5
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Reference-Multimedia-Image"
-SYSTEMD_DEFAULT_TARGET = "graphical.target"
-
IMAGE_FEATURES += " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
- '', d), d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'weston', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11-base', '', d), d)} \
"
APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
-APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
+APP_LAUNCH_WAYLAND:colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:colibri-imx6ull-emmc ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:verdin-am62 ?= "wayland-qtdemo-launch-analogclock"
-APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-qtsmarthome"
-APP_LAUNCH_X11_colibri-imx6 ?= "x-window-qtsmarthome"
-APP_LAUNCH_X11_mx7 ?= "x-window-qtsmarthome"
-APP_LAUNCH_X11_apalis-tk1 ?= "x-window-xterm"
+APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
+APP_LAUNCH_X11:colibri-imx6ull ?= "x-window-analogclock"
+APP_LAUNCH_X11:colibri-imx6ull-emmc ?= "x-window-analogclock"
+APP_LAUNCH_X11:colibri-imx7 ?= "x-window-analogclock"
+APP_LAUNCH_X11:colibri-imx7-emmc ?= "x-window-analogclock"
+APP_LAUNCH_X11:verdin-am62 ?= "x-window-analogclock"
IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
- 'weston weston-init weston-examples ${APP_LAUNCH_WAYLAND}', '', d)} \
+ '${APP_LAUNCH_WAYLAND}', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
'weston-xwayland xterm', \
bb.utils.contains('DISTRO_FEATURES', 'x11', '${APP_LAUNCH_X11}', '', d), d)} \
+ ${@bb.utils.contains("MACHINE_FEATURES", "tpm2", "packagegroup-tpm2-tdx-cli", "",d)} \
\
packagegroup-tdx-cli \
packagegroup-tdx-graphical \
packagegroup-tdx-qt5 \
+ packagegroup-fsl-isp \
\
bash \
coreutils \
less \
makedevs \
mime-support \
+ net-tools \
util-linux \
v4l-utils \
\