summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-03-12 17:55:38 +0100
committerMing Liu <ming.liu@toradex.com>2022-03-29 12:23:22 +0200
commit75f13d0ab12c85034ac742793ed820372272a7a8 (patch)
tree569a43220f067b93756407b4501660f4cfce4529 /recipes-multimedia
parent18c378510f8352bbb62d67c0e84901f553c96d7b (diff)
gstreamer1.0-plugins-base: adapt to 1.18
gstreamer1.0-plugins-base has been upgraded to 1.18 in meta-freescale, let's adapt to it. Related-to: ELB-3477 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch23
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.imx.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend3
3 files changed, 19 insertions, 9 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch
index 373d343..5dc7b66 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch
@@ -1,6 +1,6 @@
-From a2df510b1cc6d1c45614cf7e58d9f203d15ea716 Mon Sep 17 00:00:00 2001
+From e6aa0007d90071dc5405ac2188134c231b82ec88 Mon Sep 17 00:00:00 2001
From: Zan Dobersek <zdobersek@igalia.com>
-Date: Thu, 25 Mar 2021 10:27:30 +0100
+Date: Fri, 11 Mar 2022 15:50:23 +0100
Subject: [PATCH] glupload: don't reject non-RGBA output format in
_directviv_upload_accept
@@ -12,21 +12,30 @@ means picking a different uploader that won't do the job properly.
If the rejecetion is removed, the upload proceeds and the pipeline is later
reconfigured so that the DirectVIV uploader's RGBA-only output is respected,
meaning the final sink will also move over from handling I420 to RGBA.
+
+Upstream-Status: pending
+
+Signed-off-by: Zan Dobersek <zdobersek@igalia.com>
+Signed-off-by: Ming Liu <ming.liu@toradex.com>
---
- gst-libs/gst/gl/gstglupload.c | 3 ---
- 1 file changed, 3 deletions(-)
+ gst-libs/gst/gl/gstglupload.c | 4 ----
+ 1 file changed, 4 deletions(-)
diff --git a/gst-libs/gst/gl/gstglupload.c b/gst-libs/gst/gl/gstglupload.c
-index 50169adb0..079ed695e 100644
+index 78b65c1cc..9ae5e7f97 100644
--- a/gst-libs/gst/gl/gstglupload.c
+++ b/gst-libs/gst/gl/gstglupload.c
-@@ -1761,9 +1761,6 @@ _directviv_upload_accept (gpointer impl, GstBuffer * buffer, GstCaps * in_caps,
+@@ -1845,10 +1845,6 @@ _directviv_upload_accept (gpointer impl, GstBuffer * buffer, GstCaps * in_caps,
#if GST_GL_HAVE_PHYMEM
GstVideoInfo *in_info = &directviv->upload->priv->in_info;
-- GstVideoFormat fmt = GST_VIDEO_INFO_FORMAT (&directviv->upload->priv->out_info);
+- GstVideoFormat fmt =
+- GST_VIDEO_INFO_FORMAT (&directviv->upload->priv->out_info);
- if (fmt != GST_VIDEO_FORMAT_RGBA)
- return FALSE;
if (n_mem != 1 || !mem || !gst_is_phys_memory (mem)) {
GstVideoFrame frame1, frame2;
+--
+2.25.1
+
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.imx.bbappend
deleted file mode 100644
index 910fc0e..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.imx.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += " file://0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend
new file mode 100644
index 0000000..654c581
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append = " file://0001-glupload-don-t-reject-non-RGBA-output-format-in-_dir.patch"