summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend2
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb6
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb18
-rw-r--r--recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb2
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb10
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb4
-rw-r--r--recipes-bsp/u-boot/files/tegra124/fw_env.config2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc22
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb27
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend15
10 files changed, 28 insertions, 80 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
index 05bfa70..324b51b 100644
--- a/recipes-bsp/alsa-state/alsa-state.bbappend
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/alsa-state/:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/alsa-state/:"
#make this machine specific, as we have different codecs with different settings
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index a46cffe..d882cb5 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -3,18 +3,18 @@ DESCRIPTION = "Utility to create boot images with boot configuration data (BCT)
SECTION = "bootloader"
DEPENDS = ""
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
BBCLASSEXTEND = "native nativesdk"
-SRC_URI = "git://github.com/NVIDIA/cbootimage.git"
+SRC_URI = "git://github.com/NVIDIA/cbootimage.git;branch=master;protocol=https"
SRCREV = "a64c3f12b1b048096d90c44db74d3d110cea6fff"
PV = "1.7"
EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
-EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
+EXTRA_OEMAKE:class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
deleted file mode 100644
index 8cd1b8e..0000000
--- a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Configure LVDS output as extended mode in favour of primary HDMI one on Apalis TK1"
-LICENSE = "PD"
-
-SRC_URI = "file://COPYING"
-
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
-
-ALLOW_EMPTY_${PN} = "1"
-
-pkg_postinst_ontarget_${PN}() {
- mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
- echo "@xrandr --output HDMI-0 --auto --primary --output LVDS-0 --auto --right-of HDMI-0" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
- echo "#@xrandr --output LVDS-0 --auto --primary --output HDMI-0 --auto --right-of LVDS-0" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
-}
-
-pkg_postrm_${PN}() {
- sed -i /xrandr.*output.*LVDS.*off/d ${sysconfdir}/xdg/lxsession/LXDE/autostart || true
-}
diff --git a/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb b/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb
index 3eafcc7..c22bf20 100644
--- a/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb
+++ b/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENCE;md5=a1b1cf31b1b3d185409f31cb9beb25dc"
-FILES_${PN} = " /lib/firmware/apalis-tk1-k20.bin "
+FILES:${PN} = " /lib/firmware/apalis-tk1-k20.bin "
do_install () {
install -d ${D}/lib/firmware/
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index bf00d65..30a955b 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -9,10 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=395fe5affb633ad84474e42989a8e5be"
BBCLASSEXTEND = "native nativesdk"
SRC_URI = " \
- git://github.com/NVIDIA/tegrarcm.git \
+ git://github.com/NVIDIA/tegrarcm.git;branch=master;protocol=https \
file://0001-makefile-specify-cryptopp-include-path-relative-to-s.patch \
"
-SRC_URI_append_class-native = " \
+SRC_URI:append:class-native = " \
file://0001-configure.ac-link-crypotpp-as-a-static-library.patch \
file://0001-cryptopp-use-relative-path-for-cryptopp-headers.patch \
"
@@ -22,10 +22,10 @@ PV = "1.7+"
EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
-LDFLAGS_append = " -static-libstdc++"
+LDFLAGS:append = " -static-libstdc++"
-EXTRA_OEMAKE_class-native = "CC='${CC}' CXX='${CXX}'"
-EXTRA_OEMAKE_class-nativesdk = "CC='${CC}' CXX='${CXX}'"
+EXTRA_OEMAKE:class-native = "CC='${CC}' CXX='${CXX}'"
+EXTRA_OEMAKE:class-nativesdk = "CC='${CC}' CXX='${CXX}'"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
index d1bc364..7350b5d 100644
--- a/recipes-bsp/tegrastats/tegrastats.bb
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -9,13 +9,13 @@ S = "${WORKDIR}"
# Inhibit warnings about files being stripped.
# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
-INSANE_SKIP_${PN} = "already-stripped build-deps file-rdeps ldflags"
+INSANE_SKIP:${PN} = "already-stripped build-deps file-rdeps ldflags"
do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/tegrastats* ${D}${bindir}/
}
-FILES_${PN} = "${bindir}/tegrastats"
+FILES:${PN} = "${bindir}/tegrastats"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "tegra124"
diff --git a/recipes-bsp/u-boot/files/tegra124/fw_env.config b/recipes-bsp/u-boot/files/tegra124/fw_env.config
index 5941da2..1babc03 100644
--- a/recipes-bsp/u-boot/files/tegra124/fw_env.config
+++ b/recipes-bsp/u-boot/files/tegra124/fw_env.config
@@ -11,5 +11,5 @@
# block which occupies the last sector (hence -0x200)
# Block device name Device offset Env. size
-/dev/mmcblk0boot0 -0x2200 0x2000
+/dev/emmc-boot0 -0x2200 0x2000
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc b/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc
deleted file mode 100644
index 78cdb2e..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-DEPENDS += "flex-native bison-native"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
-PE = "1"
-
-PV = "2020.07+git${SRCPV}"
-inherit toradex-u-boot-localversion
-
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "3f1b0662d1a78137c923deb24099d2409ea05332"
-SRCBRANCH = "toradex_2020.07"
-SRCREV_use-head-next = "${AUTOREV}"
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-
-S = "${WORKDIR}/git"
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb b/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb
deleted file mode 100644
index ade3907..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-require u-boot-toradex-common-tk1.inc
-require recipes-bsp/u-boot/u-boot.inc
-
-B = "${WORKDIR}/build"
-
-DEPENDS += "bc-native dtc-native"
-DEPENDS_append_apalis-tk1 = " cbootimage-native"
-
-PROVIDES += "u-boot"
-
-COMPATIBLE_MACHINE = "(apalis-tk1)"
-
-SRC_URI_append_apalis-tk1 = " \
- file://apalis-tk1.img.cfg \
- file://fw_env.config \
- file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
-"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_deploy_append_apalis-tk1() {
- cd ${DEPLOYDIR}
- cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
- cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
- rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
-}
-
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..fcd3a4d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}//files:"
+DEPENDS:append:apalis-tk1 = " cbootimage-native"
+
+SRC_URI:append:apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://fw_env.config \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+
+do_deploy:append:apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}