summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/libubootenv_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/libubootenv_%.bbappend')
-rw-r--r--recipes-bsp/u-boot/libubootenv_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/libubootenv_%.bbappend b/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 0000000..3f8a71b
--- /dev/null
+++ b/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI:append = " file://fw_env.config"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RRECOMMENDS:${PN} += "u-boot-default-env"
+
+do_install:append() {
+ install -d ${D}/${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}/${sysconfdir}/
+}