summaryrefslogtreecommitdiff
path: root/recipes-devtools/mtd/mtd-utils_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/mtd/mtd-utils_%.bbappend')
-rw-r--r--recipes-devtools/mtd/mtd-utils_%.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/mtd/mtd-utils_%.bbappend b/recipes-devtools/mtd/mtd-utils_%.bbappend
new file mode 100644
index 0000000..054c939
--- /dev/null
+++ b/recipes-devtools/mtd/mtd-utils_%.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append_ = " file://ubihealthd.service"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "ubihealthd.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/ubihealthd.service ${D}${systemd_unitdir}/system/
+ sed -i -e 's,@SBINDIR@,${sbindir},g' \
+ -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+ ${D}${systemd_unitdir}/system/*.service
+}