summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-11-20 17:17:14 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-11-21 18:58:00 +0100
commit1cdea602f35d9e6e65d841cb8466201e85646c95 (patch)
tree07782fbf2aab5f1d4c11ac47a03b7f2064590760
parent531415376ca489739bffe8bdacfc861a9869138a (diff)
Machine: use the changed machinename colibri-vf
-rw-r--r--recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state922
-rw-r--r--recipes-bsp/u-boot/u-boot-colibri-vf.bb33
-rw-r--r--recipes-kernel/linux/linux-toradex-vf_git.bb13
-rw-r--r--recipes-support/icu/icu_50.1.2.bbappend6
-rw-r--r--recipes/base-files/base-files/colibri-vf/fstab (renamed from recipes/base-files/base-files/colibri-vf50/fstab)0
-rw-r--r--recipes/base-files/base-files/colibri-vf/profile (renamed from recipes/base-files/base-files/colibri-vf50/profile)0
-rw-r--r--recipes/images/angstrom-lxde-image.bb7
-rw-r--r--recipes/images/console-trdx-image.bb3
-rw-r--r--recipes/images/qt4e-demo-image.bb3
-rw-r--r--recipes/images/trdx-extra.inc4
-rw-r--r--recipes/images/trdx-image-fstype.inc6
11 files changed, 26 insertions, 971 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state b/recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state
deleted file mode 100644
index 7d61d15..0000000
--- a/recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state
+++ /dev/null
@@ -1,922 +0,0 @@
-state.colibrit20wm971 {
- control.1 {
- iface MIXER
- name 'Speaker Playback Volume'
- value.0 24
- value.1 24
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 31'
- }
- }
- control.2 {
- iface MIXER
- name 'Speaker Playback Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.3 {
- iface MIXER
- name 'Headphone Playback Volume'
- value.0 24
- value.1 24
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 31'
- }
- }
- control.4 {
- iface MIXER
- name 'Headphone Playback Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.5 {
- iface MIXER
- name 'PCM Playback Volume'
- value.0 24
- value.1 24
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 31'
- }
- }
- control.6 {
- iface MIXER
- name 'Speaker Playback ZC Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.7 {
- iface MIXER
- name 'Speaker Playback Invert Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.8 {
- iface MIXER
- name 'Headphone Playback ZC Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.9 {
- iface MIXER
- name 'Mono Playback ZC Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.10 {
- iface MIXER
- name 'Mono Playback Volume'
- value 24
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 31'
- }
- }
- control.11 {
- iface MIXER
- name 'Mono Playback Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.12 {
- iface MIXER
- name 'ALC Target Volume'
- value 11
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.13 {
- iface MIXER
- name 'ALC Hold Time'
- value 0
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.14 {
- iface MIXER
- name 'ALC Decay Time'
- value 3
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.15 {
- iface MIXER
- name 'ALC Attack Time'
- value 2
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.16 {
- iface MIXER
- name 'ALC Function'
- value None
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 None
- item.1 Left
- item.2 Right
- item.3 Stereo
- }
- }
- control.17 {
- iface MIXER
- name 'ALC Max Volume'
- value 7
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.18 {
- iface MIXER
- name 'ALC ZC Timeout'
- value 0
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 3'
- }
- }
- control.19 {
- iface MIXER
- name 'ALC ZC Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.20 {
- iface MIXER
- name 'ALC NG Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.21 {
- iface MIXER
- name 'ALC NG Type'
- value 'Constant Gain'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 'Constant Gain'
- item.1 Mute
- }
- }
- control.22 {
- iface MIXER
- name 'ALC NG Threshold'
- value 31
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 31'
- }
- }
- control.23 {
- iface MIXER
- name 'Mic Headphone Volume'
- value 4
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.24 {
- iface MIXER
- name 'ALC Headphone Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.25 {
- iface MIXER
- name 'Out3 Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.26 {
- iface MIXER
- name 'Out3 ZC Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.27 {
- iface MIXER
- name 'Out3 Volume'
- value 31
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 31'
- }
- }
- control.28 {
- iface MIXER
- name 'PCBeep Bypass Headphone Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.29 {
- iface MIXER
- name 'PCBeep Bypass Speaker Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.30 {
- iface MIXER
- name 'PCBeep Bypass Phone Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.31 {
- iface MIXER
- name 'Aux Playback Headphone Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.32 {
- iface MIXER
- name 'Aux Playback Speaker Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.33 {
- iface MIXER
- name 'Aux Playback Phone Volume'
- value 5
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 7'
- }
- }
- control.34 {
- iface MIXER
- name 'Phone Volume'
- value 7
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.35 {
- iface MIXER
- name 'Line Capture Volume'
- value.0 23
- value.1 23
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 31'
- }
- }
- control.36 {
- iface MIXER
- name 'Capture 20dB Boost Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.37 {
- iface MIXER
- name 'Capture to Phone 20dB Boost Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.38 {
- iface MIXER
- name '3D Upper Cut-off Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.39 {
- iface MIXER
- name '3D Lower Cut-off Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.40 {
- iface MIXER
- name '3D Playback Volume'
- value 0
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.41 {
- iface MIXER
- name 'Bass Control'
- value 'Linear Control'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 'Linear Control'
- item.1 'Adaptive Boost'
- }
- }
- control.42 {
- iface MIXER
- name 'Bass Cut-off Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.43 {
- iface MIXER
- name 'Tone Cut-off Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.44 {
- iface MIXER
- name 'Playback Attenuate (-6dB) Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.45 {
- iface MIXER
- name 'Bass Volume'
- value 0
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.46 {
- iface MIXER
- name 'Treble Volume'
- value 0
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 15'
- }
- }
- control.47 {
- iface MIXER
- name 'Capture ADC Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.48 {
- iface MIXER
- name 'Capture Volume Steps'
- value.0 '+1.5dB Steps'
- value.1 '+1.5dB Steps'
- comment {
- access 'read write'
- type ENUMERATED
- count 2
- item.0 '+1.5dB Steps'
- item.1 '+0.75dB Steps'
- }
- }
- control.49 {
- iface MIXER
- name 'Capture Volume'
- value.0 48
- value.1 48
- comment {
- access 'read write'
- type INTEGER
- count 2
- range '0 - 63'
- }
- }
- control.50 {
- iface MIXER
- name 'Capture ZC Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.51 {
- iface MIXER
- name 'Mic 1 Volume'
- value 23
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 31'
- }
- }
- control.52 {
- iface MIXER
- name 'Mic 2 Volume'
- value 23
- comment {
- access 'read write'
- type INTEGER
- count 1
- range '0 - 31'
- }
- }
- control.53 {
- iface MIXER
- name 'Mic 20dB Boost Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.54 {
- iface MIXER
- name 'Speaker Mixer PCBeep Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.55 {
- iface MIXER
- name 'Speaker Mixer Aux Playback Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.56 {
- iface MIXER
- name 'Speaker Mixer Phone Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.57 {
- iface MIXER
- name 'Speaker Mixer Line Bypass Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.58 {
- iface MIXER
- name 'Speaker Mixer PCM Playback Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.59 {
- iface MIXER
- name 'Phone Mixer PCBeep Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.60 {
- iface MIXER
- name 'Phone Mixer Aux Playback Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.61 {
- iface MIXER
- name 'Phone Mixer Line Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.62 {
- iface MIXER
- name 'Phone Mixer PCM Playback Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.63 {
- iface MIXER
- name 'Phone Mixer Mic 1 Sidetone Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.64 {
- iface MIXER
- name 'Phone Mixer Mic 2 Sidetone Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.65 {
- iface MIXER
- name 'Right HP Mixer PCBeep Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.66 {
- iface MIXER
- name 'Right HP Mixer Aux Playback Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.67 {
- iface MIXER
- name 'Right HP Mixer Phone Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.68 {
- iface MIXER
- name 'Right HP Mixer Line Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.69 {
- iface MIXER
- name 'Right HP Mixer PCM Playback Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.70 {
- iface MIXER
- name 'Right HP Mixer Mic Sidetone Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.71 {
- iface MIXER
- name 'Left HP Mixer PCBeep Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.72 {
- iface MIXER
- name 'Left HP Mixer Aux Playback Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.73 {
- iface MIXER
- name 'Left HP Mixer Phone Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.74 {
- iface MIXER
- name 'Left HP Mixer Line Bypass Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.75 {
- iface MIXER
- name 'Left HP Mixer PCM Playback Switch'
- value true
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.76 {
- iface MIXER
- name 'Left HP Mixer Mic Sidetone Switch'
- value false
- comment {
- access 'read write'
- type BOOLEAN
- count 1
- }
- }
- control.77 {
- iface MIXER
- name 'Differential Source'
- value Mic
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 Mic
- item.1 Line
- }
- }
- control.78 {
- iface MIXER
- name 'Mic Select Source'
- value 'Mic 1'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 'Mic 1'
- item.1 Differential
- item.2 'Mic 2'
- item.3 Stereo
- }
- }
- control.79 {
- iface MIXER
- name 'Right Capture Select'
- value Mic
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 Mic
- item.1 NC
- item.2 NC
- item.3 'Speaker Mixer'
- item.4 Line
- item.5 'Headphone Mixer'
- item.6 'Phone Mixer'
- item.7 Phone
- }
- }
- control.80 {
- iface MIXER
- name 'Left Capture Select'
- value Mic
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 Mic
- item.1 NC
- item.2 NC
- item.3 'Speaker Mixer'
- item.4 Line
- item.5 'Headphone Mixer'
- item.6 'Phone Mixer'
- item.7 Phone
- }
- }
- control.81 {
- iface MIXER
- name 'Capture Phone Mux'
- value Mute
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 Stereo
- item.1 Left
- item.2 Right
- item.3 Mute
- }
- }
- control.82 {
- iface MIXER
- name 'Speaker Mux'
- value 'Speaker Mix'
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 'Speaker Mix'
- item.1 'Headphone Mix'
- }
- }
- control.83 {
- iface MIXER
- name 'Out3 Mux'
- value Left
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 Left
- item.1 VREF
- item.2 'Left + Right'
- item.3 Mono
- }
- }
- control.84 {
- iface MIXER
- name 'ALC Sidetone Mux'
- value None
- comment {
- access 'read write'
- type ENUMERATED
- count 1
- item.0 Stereo
- item.1 Left
- item.2 Right
- item.3 None
- }
- }
-}
diff --git a/recipes-bsp/u-boot/u-boot-colibri-vf.bb b/recipes-bsp/u-boot/u-boot-colibri-vf.bb
index ae2ddc8..cd84206 100644
--- a/recipes-bsp/u-boot/u-boot-colibri-vf.bb
+++ b/recipes-bsp/u-boot/u-boot-colibri-vf.bb
@@ -11,36 +11,19 @@ PR = "r0"
S = "${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRCREV_colibri-vf50 = "ac13ca97df9f8c17d1c89d425041690484ee0fdf"
+SRCREV_colibri-vf = "ac13ca97df9f8c17d1c89d425041690484ee0fdf"
#FILESPATHPKG =. "git:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "colibri-vf50"
-DEFAULT_PREFERENCE_colibri-vf50 = "1"
+COMPATIBLE_MACHINE = "colibri-vf"
+DEFAULT_PREFERENCE_colibri-vf = "1"
-# colibri_vf50: build additionally a u-boot binary used for nand boot
-#SPL_BINARY_colibri-vf50 = "u-boot.nand"
-#SPL_IMAGE_colibri-vf50 = "u-boot-${MACHINE}-${PV}-${PR}.nand"
-#SPL_SYMLINK_colibri-vf50 = "u-boot-${MACHINE}.nand"
-#do_compile_append_colibri-vf50() {
-# # keep boot-hsmmc
-# mv u-boot.${UBOOT_SUFFIX} u-boot-mmc.${UBOOT_SUFFIX}
-# oe_runmake colibri_vf50_nand_config
-# oe_runmake ${UBOOT_MAKE_TARGET}
-# mv u-boot.${UBOOT_SUFFIX} u-boot-nand.${UBOOT_SUFFIX}
-# mv u-boot-mmc.${UBOOT_SUFFIX} u-boot.${UBOOT_SUFFIX}
-#
-# # prepare the u-boot for nand
-# dd if=/dev/zero of=u-boot-pad bs=1024 count=1
-# cat u-boot-pad u-boot-nand.${UBOOT_SUFFIX} > ${SPL_BINARY}
-#}
-
-# colibri_vf50: build additionally a u-boot binary used for sd-card boot
-SPL_BINARY_colibri-vf50 = "u-boot.imx"
-SPL_IMAGE_colibri-vf50 = "u-boot-${MACHINE}-${PV}-${PR}.imx"
-SPL_SYMLINK_colibri-vf50 = "u-boot-${MACHINE}.imx"
-do_compile_append_colibri-vf50() {
+# colibri_vf: build additionally a u-boot binary used for sd-card boot
+SPL_BINARY_colibri-vf = "u-boot.imx"
+SPL_IMAGE_colibri-vf = "u-boot-${MACHINE}-${PV}-${PR}.imx"
+SPL_SYMLINK_colibri-vf = "u-boot-${MACHINE}.imx"
+do_compile_append_colibri-vf() {
oe_runmake colibri_vf50_sdboot_config
oe_runmake
}
diff --git a/recipes-kernel/linux/linux-toradex-vf_git.bb b/recipes-kernel/linux/linux-toradex-vf_git.bb
index 540c924..d5eff6d 100644
--- a/recipes-kernel/linux/linux-toradex-vf_git.bb
+++ b/recipes-kernel/linux/linux-toradex-vf_git.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux.inc
LINUX_VERSION ?= "3.0.15"
-SRCREV_colibri-vf50 = "87af4ef6e63b55de3c34cd20e9ebb54b0e0ded05"
-PR_colibri-vf50 = "V2.1b1"
+SRCREV_colibri-vf = "fff8692e9818f930c0e40c3e1a631799fb78c13f"
+PR_colibri-vf = "V2.1b2"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
@@ -13,7 +13,7 @@ SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri_v
# SRC_URI += "file://a.patch "
-COMPATIBLE_MACHINE_colibri-vf50 = "colibri-vf50"
+COMPATIBLE_MACHINE_colibri-vf = "colibri-vf"
# Place changes to the defconfig here
config_script () {
@@ -21,10 +21,6 @@ config_script () {
# #sets CONFIG_TEGRA_CAMERA unconditionally to 'y'
# sed -i -e /CONFIG_TEGRA_CAMERA/d ${S}/.config
# echo "CONFIG_TEGRA_CAMERA=y" >> ${S}/.config
- sed -i -e /CONFIG_VFPv3/d ${S}/.config
- echo "CONFIG_VFPv3=y" >> ${S}/.config
- sed -i -e /CONFIG_NEON/d ${S}/.config
- echo "CONFIG_NEON=y" >> ${S}/.config
echo "dummy" > /dev/null
}
@@ -33,6 +29,9 @@ do_configure_prepend () {
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
+ #until we have the unified kernel
+ DEFCONFIG=colibri_vf50_defconfig
+
oe_runmake $DEFCONFIG
#maybe change some configuration
diff --git a/recipes-support/icu/icu_50.1.2.bbappend b/recipes-support/icu/icu_50.1.2.bbappend
index 61b789d..3a079ad 100644
--- a/recipes-support/icu/icu_50.1.2.bbappend
+++ b/recipes-support/icu/icu_50.1.2.bbappend
@@ -1,12 +1,12 @@
# use a customized icu data library created from
# http://apps.icu-project.org/datacustom/ICUData50.html
-PRINC_colibri-vf50 = "1"
+PRINC_colibri-vf = "1"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_colibri-vf50 = "${BASE_SRC_URI} file://icudt50l.zip "
+SRC_URI_colibri-vf = "${BASE_SRC_URI} file://icudt50l.zip "
-do_configure_append_colibri-vf50 () {
+do_configure_append_colibri-vf () {
rm ${S}/data/in/icudt50l.dat
cp ${WORKDIR}/icudt50l.dat ${S}/data/in/
}
diff --git a/recipes/base-files/base-files/colibri-vf50/fstab b/recipes/base-files/base-files/colibri-vf/fstab
index fea4501..fea4501 100644
--- a/recipes/base-files/base-files/colibri-vf50/fstab
+++ b/recipes/base-files/base-files/colibri-vf/fstab
diff --git a/recipes/base-files/base-files/colibri-vf50/profile b/recipes/base-files/base-files/colibri-vf/profile
index c1ee240..c1ee240 100644
--- a/recipes/base-files/base-files/colibri-vf50/profile
+++ b/recipes/base-files/base-files/colibri-vf/profile
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index 0744fda..4753f4f 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -12,8 +12,7 @@ IMAGE_NAME_colibri-t20 = "Colibri_T20_LinuxImage"
IMAGE_NAME_colibri-t30 = "Colibri_T30_LinuxImage"
IMAGE_NAME_apalis-t30 = "Apalis_T30_LinuxImage"
IMAGE_NAME_colibri-pxa = "Colibri_PXA_LinuxImage"
-IMAGE_NAME_colibri-vf50 = "Colibri_VF50_LinuxImage"
-IMAGE_NAME_colibri-vf61 = "Colibri_VF61_LinuxImage"
+IMAGE_NAME_colibri-vf = "Colibri_VF_LinuxImage"
IMAGE_NAME = "${MACHINE}_LinuxImage"
#create the deployment directory-tree
@@ -39,7 +38,7 @@ DEPENDS_tegra += "nvsamples"
IMAGE_BROWSER = "firefox"
#keep the rootfs size small
-IMAGE_BROWSER_colibri-vf50 = "midori"
+IMAGE_BROWSER_colibri-vf = "midori"
# this recommends from midori pulls in 8Meg of icons
BAD_RECOMMENDATIONS += " gnome-icon-theme "
@@ -82,7 +81,7 @@ GSTREAMER = " \
gst-plugins-good-wavparse \
gst-plugins-ugly-asf \
"
-GSTREAMER_colibri-vf50 = ""
+GSTREAMER_colibri-vf = ""
IMAGE_INSTALL += " \
gconf \
diff --git a/recipes/images/console-trdx-image.bb b/recipes/images/console-trdx-image.bb
index 995db1a..3fe52b3 100644
--- a/recipes/images/console-trdx-image.bb
+++ b/recipes/images/console-trdx-image.bb
@@ -12,8 +12,7 @@ IMAGE_NAME_colibri-t20 = "Colibri_T20_LinuxConsoleImage"
IMAGE_NAME_colibri-t30 = "Colibri_T30_LinuxConsoleImage"
IMAGE_NAME_apalis-t30 = "Apalis_T30_LinuxConsoleImage"
IMAGE_NAME_colibri-pxa = "Colibri_PXA_LinuxConsoleImage"
-IMAGE_NAME_colibri-vf50 = "Colibri_VF50_LinuxConsoleImage"
-IMAGE_NAME_colibri-vf61 = "Colibri_VF61_LinuxConsoleImage"
+IMAGE_NAME_colibri-vf = "Colibri_VF_LinuxConsoleImage"
IMAGE_NAME = "${MACHINE}_LinuxConsoleImage"
#create the deployment directory-tree
diff --git a/recipes/images/qt4e-demo-image.bb b/recipes/images/qt4e-demo-image.bb
index 82b92f8..8d7b974 100644
--- a/recipes/images/qt4e-demo-image.bb
+++ b/recipes/images/qt4e-demo-image.bb
@@ -9,8 +9,7 @@ PR = "r0"
#start of the resulting deployable tarball name
IMAGE_NAME_colibri-pxa = "Colibri_PXA_LinuxImage-qte"
-IMAGE_NAME_colibri-vf50 = "Colibri_VF50_LinuxImage-qte"
-IMAGE_NAME_colibri-vf61 = "Colibri_VF61_LinuxImage-qte"
+IMAGE_NAME_colibri-vf = "Colibri_VF_LinuxImage-qte"
IMAGE_NAME = "${MACHINE}_LinuxImage-qte"
#create the deployment directory-tree
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index c6fe6bb..9526395 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -58,9 +58,7 @@ IMAGE_INSTALL_MACHINE_apalis-t30 = "${IMAGE_INSTALL_T20_T30} \
kernel-module-videobuf2-memops \
"
-IMAGE_INSTALL_MACHINE_colibri-vf50 = "${IMAGE_INSTALL_VF}"
-
-IMAGE_INSTALL_MACHINE_colibri-vf61 = "${IMAGE_INSTALL_VF}"
+IMAGE_INSTALL_MACHINE_colibri-vf = "${IMAGE_INSTALL_VF}"
IMAGE_INSTALL_MACHINE = ""
diff --git a/recipes/images/trdx-image-fstype.inc b/recipes/images/trdx-image-fstype.inc
index e91ee65..eeb39b1 100644
--- a/recipes/images/trdx-image-fstype.inc
+++ b/recipes/images/trdx-image-fstype.inc
@@ -6,7 +6,7 @@ S = "${WORKDIR}/burnflash"
IMAGE_ROOTFS = "${WORKDIR}/${IMAGE_NAME}${PV}/rootfs"
U_BOOT_EXT = "bin"
-U_BOOT_EXT_colibri-vf50 = "imx"
+U_BOOT_EXT_colibri-vf = "imx"
do_rootfs_prepend() {
tar -C ${WORKDIR} -xf ${BURNFLASH}
@@ -15,9 +15,9 @@ do_rootfs_prepend() {
}
#we need the native ubi tools for machines using ubifs
-DEPENDS_colibri-vf50 = "mtd-utils-native"
+DEPENDS_colibri-vf = "mtd-utils-native"
CP_MKUBIFS=""
-CP_MKUBIFS_colibri-vf50="MKUBIFS=`which mkfs.ubifs` ; mkdir ${IMAGE_ROOTFS}/../vf_flash/ ; cp ${MKUBIFS} ${IMAGE_ROOTFS}/../vf_flash/ ; ${BUILD_STRIP} ${IMAGE_ROOTFS}/../vf_flash/mkfs.ubifs"
+CP_MKUBIFS_colibri-vf="MKUBIFS=`which mkfs.ubifs` ; mkdir ${IMAGE_ROOTFS}/../vf_flash/ ; cp ${MKUBIFS} ${IMAGE_ROOTFS}/../vf_flash/ ; ${BUILD_STRIP} ${IMAGE_ROOTFS}/../vf_flash/mkfs.ubifs"
do_rootfs_append() {
# put u-boot, kernel into the bin directories, remove the kernel from the rootfs/boot