summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-10-07 10:08:07 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-10-14 13:51:19 +0200
commitd39eb867352f2a9d48c4fed10b6c648a640a2e5a (patch)
tree260cd1d55926e658838eff26f2cbde5aa0920b79
parent5ad4bd8f267bf17270c4913cc1bd034d7c644ab7 (diff)
dropbear: dont set PACKAGECONFIG to empty
Directly set PACKAGECONFIG is risky, it could override the same variable in other layers, let's change to use PACKAGECONFIG:remove instead. Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit fb417309b02aeffb89f38e95af1f55d5419f7321)
-rw-r--r--recipes-core/dropbear/dropbear_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/dropbear/dropbear_%.bbappend b/recipes-core/dropbear/dropbear_%.bbappend
index 0083f42..587c497 100644
--- a/recipes-core/dropbear/dropbear_%.bbappend
+++ b/recipes-core/dropbear/dropbear_%.bbappend
@@ -3,4 +3,4 @@
# If debug-tweaks is set in IMAGE_FEATURES then enable also weak ciphers.
# With debug-tweaks we allow password less root access, enforcing strong
# ciphers is pointless anyway.
-PACKAGECONFIG = "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "", "disable-weak-ciphers",d)}"
+PACKAGECONFIG:remove = "${@bb.utils.contains('IMAGE_FEATURES', 'debug-tweaks', 'disable-weak-ciphers', '',d)}"