summaryrefslogtreecommitdiff
path: root/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'qt5-layer/recipes-qt/qt5/qtbase_%.bbappend')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend16
1 files changed, 8 insertions, 8 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 2d1f9d6..83eeb1a 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -7,31 +7,31 @@ PACKAGECONFIG_EXAMPLES ?= "examples"
# | /build/krm/oe-core_V2.6/build/out-glibc/work/armv7at2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.1+gitAUTOINC+5afc431323-r0/git/src/widgets/styles/qgtkstyle.cpp:3636:74: error: 'QAccessible' has not been declared
# | } else if (QStyleHelper::isInstanceOf(groupBox->styleObject, QAccessible::Grouping)) {
-PACKAGECONFIG_append = " accessibility"
-PACKAGECONFIG_append = " sql-sqlite"
+PACKAGECONFIG:append = " accessibility"
+PACKAGECONFIG:append = " sql-sqlite"
-PACKAGECONFIG_FONTS_append = " fontconfig"
+PACKAGECONFIG_FONTS:append = " fontconfig"
#qtbase must be configured with icu for qtwebkit
-PACKAGECONFIG_append = " \
+PACKAGECONFIG:append = " \
icu \
${PACKAGECONFIG_EXAMPLES} \
"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
IMX_BACKEND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
'fb', d), d)}"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://qt5-${IMX_BACKEND}.sh \
"
-do_install_append () {
+do_install:append () {
install -d ${D}${sysconfdir}/profile.d/
install -m 0755 ${WORKDIR}/qt5-${IMX_BACKEND}.sh ${D}${sysconfdir}/profile.d/
}
-FILES_${PN} += "${sysconfdir}/profile.d/qt5*.sh"
+FILES:${PN} += "${sysconfdir}/profile.d/qt5*.sh"