summaryrefslogtreecommitdiff
path: root/recipes-images/images/tdx-reference-multimedia-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images/images/tdx-reference-multimedia-image.bb')
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb32
1 files changed, 15 insertions, 17 deletions
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 4acb778..4299e81 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -8,35 +8,32 @@ inherit populate_sdk_qt5
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Reference-Multimedia-Image"
-# Show Tezi EULA license
-TEZI_SHOW_EULA_LICENSE ?= "1"
-
-SYSTEMD_DEFAULT_TARGET = "graphical.target"
-
IMAGE_FEATURES += " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
- '', d), d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'weston', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11-base', '', d), d)} \
"
APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
-APP_LAUNCH_WAYLAND_colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
-APP_LAUNCH_WAYLAND_colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
-APP_LAUNCH_WAYLAND_colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
-APP_LAUNCH_WAYLAND_apalis-tk1 ?= "wayland-qtdemo-launch-qtsmarthome"
+APP_LAUNCH_WAYLAND:colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:colibri-imx6ull-emmc ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND:verdin-am62 ?= "wayland-qtdemo-launch-analogclock"
APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
-APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-analogclock"
-APP_LAUNCH_X11_colibri-imx7 ?= "x-window-analogclock"
-APP_LAUNCH_X11_colibri-imx7-emmc ?= "x-window-analogclock"
-APP_LAUNCH_X11_apalis-tk1 ?= "x-window-qtsmarthome"
+APP_LAUNCH_X11:colibri-imx6ull ?= "x-window-analogclock"
+APP_LAUNCH_X11:colibri-imx6ull-emmc ?= "x-window-analogclock"
+APP_LAUNCH_X11:colibri-imx7 ?= "x-window-analogclock"
+APP_LAUNCH_X11:colibri-imx7-emmc ?= "x-window-analogclock"
+APP_LAUNCH_X11:verdin-am62 ?= "x-window-analogclock"
IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
- 'weston weston-init weston-examples ${APP_LAUNCH_WAYLAND}', '', d)} \
+ '${APP_LAUNCH_WAYLAND}', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
'weston-xwayland xterm', \
bb.utils.contains('DISTRO_FEATURES', 'x11', '${APP_LAUNCH_X11}', '', d), d)} \
+ ${@bb.utils.contains("MACHINE_FEATURES", "tpm2", "packagegroup-tpm2-tdx-cli", "",d)} \
\
packagegroup-tdx-cli \
packagegroup-tdx-graphical \
@@ -48,6 +45,7 @@ IMAGE_INSTALL += " \
less \
makedevs \
mime-support \
+ net-tools \
util-linux \
v4l-utils \
\