summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-03-13 18:59:08 +0100
committerMing Liu <ming.liu@toradex.com>2022-04-01 11:11:36 +0200
commit505e1f9cd1531f13c0257bc5fa748e0738cea199 (patch)
treec750efd0aba836af960a05444918ce372529303d
parent831f8d07f08ab9d03c9b9f40f9c02124c3be0b54 (diff)
weston-init: drop bbappend recipe
Move it to meta-toradex-bsp-common, so it could be applied to meta-toradex-tegra layer as well. Related-to: ELB-3477 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend49
1 files changed, 0 insertions, 49 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
deleted file mode 100644
index 565443e..0000000
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ /dev/null
@@ -1,49 +0,0 @@
-INI_UNCOMMENT_ASSIGNMENTS:append:mx8-nxp-bsp = " \
- use-g2d=1 \
-"
-
-
-uncomment() {
- # already uncommented, do nothing
- if ! (grep "^$1" $2); then
- if ! (grep "^#$1" $2); then
- bbfatal "Commented setting '#$1' not found in file $2"
- fi
- sed -i -e 's,^#'"$1"','"$1"',g' $2
- fi
-}
-
-
-configure_noidle() {
- sed -i '/idle-time=0/d' ${D}${sysconfdir}/xdg/weston/weston.ini
- sed -i '/^\[core\]/a idle-time=0' ${D}${sysconfdir}/xdg/weston/weston.ini
-}
-
-# Prevent weston from going to sleep
-do_install:append:upstream() {
- configure_noidle
-}
-
-configure_pixman() {
- sed -i '/use-pixman=true/d' ${D}${sysconfdir}/xdg/weston/weston.ini
- sed -i '/^\[core\]/a use-pixman=true' ${D}${sysconfdir}/xdg/weston/weston.ini
-}
-
-# With upstream weston and modules without GPU weston uses a lot of
-# cpu time and becomes very unresponsive. Setting use-pixman=true works
-# around it.
-do_install:append:upstream:colibri-imx6ull() {
- configure_pixman
-}
-
-do_install:append:upstream:colibri-imx6ull-emmc() {
- configure_pixman
-}
-
-do_install:append:upstream:colibri-imx7() {
- configure_pixman
-}
-
-do_install:append:upstream:colibri-imx7-emmc() {
- configure_pixman
-}