summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-02-20 16:07:19 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2022-02-28 14:14:19 +0100
commit71f353356afdbed5bd1f7ae6abd1297206c58e6e (patch)
tree2929dc3436dfe1ae3d02fb5cf40371e41c09539f
parent43bd049d3dd0139df15efb7f0a5958f96d6eca89 (diff)
layer: rework recipes to use soc familiy overrides
Follow meta-freescale commit 30f5ce1d ("Generalize overrides subsystem for NXP and Mainline support"). Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>layer: rework recipes to use soc familiy overrides
-rw-r--r--recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc4
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend2
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb6
5 files changed, 9 insertions, 9 deletions
diff --git a/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb b/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb
index e7eb7aa..73c0d27 100644
--- a/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb
+++ b/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb
@@ -22,8 +22,8 @@ RPROVIDES:${PN} = "imx-sc-firmware"
RCONFLICTS:${PN} = "imx-sc-firmware"
BOARD_TYPE ?= "unknown"
-SC_FIRMWARE_NAME:mx8qm = "mx8qm-${BOARD_TYPE}-scfw-tcm.bin"
-SC_FIRMWARE_NAME:mx8qxp = "mx8qx-${BOARD_TYPE}-scfw-tcm.bin"
+SC_FIRMWARE_NAME:mx8qm-nxp-bsp = "mx8qm-${BOARD_TYPE}-scfw-tcm.bin"
+SC_FIRMWARE_NAME:mx8qxp-nxp-bsp = "mx8qx-${BOARD_TYPE}-scfw-tcm.bin"
symlink_name = "scfw_tcm.bin"
BOOT_TOOLS = "imx-boot-tools"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common.inc b/recipes-bsp/u-boot/u-boot-toradex-common.inc
index f902e7d..b06c047 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-common.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-common.inc
@@ -25,7 +25,7 @@ S = "${WORKDIR}/git"
UBOOT_INITIAL_ENV = "u-boot-initial-env"
-do_deploy:append:mx8m() {
+do_deploy:append:mx8m-generic-bsp() {
# Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
if [ -n "${UBOOT_CONFIG}" ]
then
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc b/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
index 553fb3a..0364a8d 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
@@ -20,10 +20,10 @@ inherit toradex-u-boot-localversion
UBOOT_INITIAL_ENV = "u-boot-initial-env"
-COMPATIBLE_MACHINE = "(mx8)"
+COMPATIBLE_MACHINE = "(mx8-generic-bsp)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_deploy:append:mx8m() {
+do_deploy:append:mx8m-generic-bsp() {
# Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
if [ -n "${UBOOT_CONFIG}" ]
then
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 1ba5ed4..565443e 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -1,4 +1,4 @@
-INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \
+INI_UNCOMMENT_ASSIGNMENTS:append:mx8-nxp-bsp = " \
use-g2d=1 \
"
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb
index b803c9d..07738ac 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb
@@ -26,14 +26,14 @@ SRCREV_machine = "e395d949e46b9b80358668b42b07b85738e5758d"
SRCREV_machine:use-head-next = "${AUTOREV}"
DEPENDS += "lzop-native bc-native"
-COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
+COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
KBUILD_DEFCONFIG:apalis-imx6 ?= "apalis_imx6_defconfig"
KBUILD_DEFCONFIG:colibri-imx6 ?= "colibri_imx6_defconfig"
KBUILD_DEFCONFIG:colibri-imx6ull ?= "colibri-imx6ull_defconfig"
KBUILD_DEFCONFIG:colibri-imx6ull-emmc ?= "colibri-imx6ull_defconfig"
-KBUILD_DEFCONFIG:mx7 ?= "colibri_imx7_defconfig"
-KBUILD_DEFCONFIG:mx8 ?= "toradex_defconfig"
+KBUILD_DEFCONFIG:mx7-nxp-bsp ?= "colibri_imx7_defconfig"
+KBUILD_DEFCONFIG:mx8-nxp-bsp ?= "toradex_defconfig"
export DTC_FLAGS = "-@"