summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-07-30 16:52:34 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-08-08 14:59:58 +0000
commit797bb81ad461bbdc538b391fa7bd22e24d80f372 (patch)
treef2a1675609676c88602e0b80c8e24a7471765918
parent6a463bcfabdeb328b882fdd1fd2c8c984828b98a (diff)
u-boot-toradex_2020.07: drop recipe
We now use the openembedded-core u-boot recipe with a bbappend in meta-toradex-bsp-common. Related-to: ELB-4581 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common.inc44
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2020.07.bb56
2 files changed, 0 insertions, 100 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common.inc b/recipes-bsp/u-boot/u-boot-toradex-common.inc
deleted file mode 100644
index 8562341..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-common.inc
+++ /dev/null
@@ -1,44 +0,0 @@
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-DEPENDS += "flex-native bison-native"
-
-LICENSE = "GPL-2.0-or-later"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
-PE = "1"
-
-PV = "2020.07+git${SRCPV}"
-
-inherit toradex-u-boot-localversion
-
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "1cbeecee44a868f4ace933a992e730efb6d9d654"
-SRCBRANCH = "toradex_2020.07"
-SRCREV:use-head-next = "${AUTOREV}"
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-
-S = "${WORKDIR}/git"
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
-
-do_deploy:append:mx8m-generic-bsp() {
- # Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
- fi
- done
- unset j
- done
- unset i
- fi
-}
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
deleted file mode 100644
index c608982..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
+++ /dev/null
@@ -1,56 +0,0 @@
-require u-boot-toradex-common.inc
-require recipes-bsp/u-boot/u-boot.inc
-
-B = "${WORKDIR}/build"
-
-PROVIDES += "u-boot"
-
-DEPENDS += "bc-native dtc-native"
-
-# While NXP i.MX 7 downstream requires the Linux kernel to boot in secure
-# mode mainline/upstream requires non-secure mode instead, as it properly
-# uses PSCI to control further cores.
-SRC_URI:append:use-mainline-bsp:colibri-imx7 = " file://0001-colibri_imx7-boot-linux-kernel-in-non-secure-mode.patch"
-SRC_URI:append:use-mainline-bsp:colibri-imx7-emmc = " file://0001-colibri_imx7-boot-linux-kernel-in-non-secure-mode.patch"
-
-BOOT_TOOLS = "imx-boot-tools"
-
-PADDING_DIR = "${B}"
-
-nand_padding () {
- # pad the end of U-Boot with 0x00 up to the the end of the CSF area
- #PAD_END=$(echo -n "0x"; od -X -j 0x24 -N 4 u-boot.imx | sed -e '/................/!d' -e 's/........\(.*\)/\1/')
- #PAD_END=$(( $PAD_END - 0x400 ))
- #objcopy -I binary -O binary --pad-to $PAD_END u-boot.imx u-boot.imx.zero-padded
- # assume that the above never need more than 10k of padding and skip the
- # shell magic to get a correct size.
- dd bs=10k count=1 if=/dev/zero | cat ${PADDING_DIR}/u-boot.imx - > ${PADDING_DIR}/u-boot.imx.zero-padded
-
- # U-Boot is flashed 1k into a NAND block, create a binary which prepends
- # U-boot with 1k of zeros to ease flashing
- dd bs=1024 count=1 if=/dev/zero | cat - ${PADDING_DIR}/u-boot.imx.zero-padded > ${PADDING_DIR}/u-boot-nand.imx
-}
-
-deploy_uboot_with_spl () {
- for config in ${UBOOT_MACHINE}; do
- if [ -f "${B}/${config}/u-boot-with-spl.imx" ]; then
- install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx
- fi
- done
-}
-
-do_compile:append:colibri-imx6ull () {
- nand_padding
-}
-
-do_compile:append:colibri-imx7 () {
- nand_padding
-}
-
-do_deploy:append:colibri-imx6 () {
- deploy_uboot_with_spl
-}
-
-do_deploy:append:apalis-imx6 () {
- deploy_uboot_with_spl
-}