summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eichenberger <stefan.eichenberger@toradex.com>2023-02-17 13:42:52 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-02-26 15:01:28 +0100
commit8961740c789241b1325138fb1434adda6b649512 (patch)
treea87cb8e901522398a315055e6e24044c3e3ac0bd
parent71bb260c7a6bbe607b37dbb7889a41bda6d30d12 (diff)
btuart: remove recipe
Remove the btuart recipe. This is not required anymore because we now load the driver through a serdev entry in the device tree. Related-to: ELB-5030 Signed-off-by: Stefan Eichenberger <stefan.eichenberger@toradex.com> (cherry picked from commit 3488268909517eb9729270975dbce5b43b01749f)
-rw-r--r--recipes-support/btuart/btuart.bb37
-rw-r--r--recipes-support/btuart/files/COPYING5
-rw-r--r--recipes-support/btuart/files/btuart.service13
-rwxr-xr-xrecipes-support/btuart/files/btuart.sh8
4 files changed, 0 insertions, 63 deletions
diff --git a/recipes-support/btuart/btuart.bb b/recipes-support/btuart/btuart.bb
deleted file mode 100644
index dabe9d4..0000000
--- a/recipes-support/btuart/btuart.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SUMMARY = "Initialize Bluetooth UART"
-DESCRIPTION = "At runtime on target make sure appropriate firmware is used and initialize Bluetooth UART"
-LICENSE = "PD"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-RRECOMMENDS:${PN} = "bluez5"
-
-SRC_URI = " \
- file://btuart.sh \
- file://btuart.service \
- file://COPYING \
-"
-
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
-
-do_install () {
- install -d ${D}/${sbindir}
- install -m 0755 ${WORKDIR}/*.sh ${D}/${sbindir}
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/btuart.service ${D}${systemd_unitdir}/system
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "btuart.service"
-
-inherit allarch systemd
-
-pkg_postinst_ontarget:${PN}:verdin-imx8mp () {
- # only BT UART modules need our service
- if fgrep -q V1.0 /proc/device-tree/toradex,board-rev || ! fgrep -q toradex,verdin-imx8mp-wifi /proc/device-tree/compatible; then
- /bin/systemctl disable btuart.service
- /bin/systemctl stop btuart.service
- exit 0
- fi
-}
diff --git a/recipes-support/btuart/files/COPYING b/recipes-support/btuart/files/COPYING
deleted file mode 100644
index 040e990..0000000
--- a/recipes-support/btuart/files/COPYING
+++ /dev/null
@@ -1,5 +0,0 @@
-This piece is software is provided by Toradex AG as sample code.
-There is no warranty for the program.
-Toradex AG put this program in public domain, uncopyrighted.
-
-Renens, Swizterland, 2008-10-23
diff --git a/recipes-support/btuart/files/btuart.service b/recipes-support/btuart/files/btuart.service
deleted file mode 100644
index 547f6be..0000000
--- a/recipes-support/btuart/files/btuart.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Initialize Bluetooth UART
-Wants=bluetooth.service
-Before=bluetooth.service
-After=sys-subsystem-net-devices-mlan0.device
-After=dev-ttymxc3.device
-
-[Service]
-Type=forking
-ExecStart=/usr/sbin/btuart.sh
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-support/btuart/files/btuart.sh b/recipes-support/btuart/files/btuart.sh
deleted file mode 100755
index c4f53c1..0000000
--- a/recipes-support/btuart/files/btuart.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-sleep 5
-/usr/bin/hciattach /dev/ttymxc3 any 115200 flow
-/usr/sbin/rfkill unblock bluetooth
-/usr/bin/hciconfig hci0 up
-# Change BT UART baudrate to a higher speed, for example 921600
-/usr/bin/hcitool -i hci0 cmd 0x3F 0x09 0x00 0x10 0x0e 0x00
-/bin/stty -F /dev/ttymxc3 921600