summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-03-09 15:46:54 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-09 18:53:14 +0200
commitf6820bb2d1f0e987121ebec3010a98e4f70cbb08 (patch)
tree84c54b2076a9dcf6c3933a5fab8505af6f86e631
parent43c386c6d2df844742e9c6439306cbdf813fee75 (diff)
weston.ini: use g2d for soc which support g2d
For apalis-imx8 this makes gst-play and the gstreamer playbin plugin automatically convert the tiling output of the vpu decoder to the video sink plugins requirement. Related-to: ELB-2351 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit b5fd4d1e039ff265cdeb1f401d5c34a7110e31bd) (cherry picked from commit 0ab9b1dab586cb237a1f973abedc1edbb48202c8)
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend14
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bbappend1
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 0000000..c92a3c6
--- /dev/null
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,14 @@
+INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \
+ use-g2d=1 \
+"
+
+
+uncomment() {
+ # already uncommented, do nothing
+ if ! (grep "^$1" $2); then
+ if ! (grep "^#$1" $2); then
+ bbfatal "Commented setting '#$1' not found in file $2"
+ fi
+ sed -i -e 's,^#'"$1"','"$1"',g' $2
+ fi
+}
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bbappend b/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
index 9cb3de2..ba8d20f 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bbappend
@@ -1,3 +1,2 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/weston:"
-SRC_URI += "file://weston.ini"
SRCREV = "73a26456e43b6d4f72f0a995d437590065cafb15"