summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-09-14 14:32:27 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-09-14 14:32:27 +0200
commit853b15071139b66be1723be0491881c0c390331b (patch)
treeccd5c717d665504bf4c1fa687e7c2f6604b9040f
parentd5e549115091f5b808abdfd0721c2656d11b74df (diff)
xserver-xorg: Backport patch to remove using sys/io.h
latest glibc dropped support for sys/io.h on arm, which is fixed in upstream xserver, as a bonus we can drop musl specific patch which was doing something similar up until now. Fixes |In file included from ../../../../xorg-server-1.20.4/hw/xfree86/int10/generic.c:15: | ../../../../xorg-server-1.20.4/hw/xfree86/common/compiler.h:767:10: fatal error: 'sys/io.h' file not found | #include <sys/io.h> | ^~~~~~~~~~ | 1 error generated. (From OE-Core rev: 1c72953b6c890b8411fec997b5c28a17eed82897) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch63
-rwxr-xr-xrecipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb5
2 files changed, 67 insertions, 1 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch
new file mode 100644
index 0000000..da9a4f2
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch
@@ -0,0 +1,63 @@
+From 2ba9510721b7a76cb7fe507449fa0ac997a4cce3 Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <ofourdan@redhat.com>
+Date: Mon, 1 Jul 2019 13:20:39 +0200
+Subject: [PATCH] compiler.h: Do not include sys/io.h on ARM with glibc
+
+<sys/io.h> on ARM hasn't worked for a long, long time, so it was removed
+it from glibc upstream.
+
+Remove the include to avoid a compilation failure on ARM with glibc.
+
+Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
+Closes: https://gitlab.freedesktop.org/xorg/xserver/issues/840
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Backport [https://gitlab.freedesktop.org/xorg/xserver/commit/fe4cd0e7f5c58fa94db36326aadc1bd4e6d73eba]
+---
+ hw/xfree86/common/compiler.h | 30 ------------------------------
+ 1 file changed, 30 deletions(-)
+
+diff --git a/hw/xfree86/common/compiler.h b/hw/xfree86/common/compiler.h
+index 7144c6a..2b2008b 100644
+--- a/hw/xfree86/common/compiler.h
++++ b/hw/xfree86/common/compiler.h
+@@ -758,36 +758,6 @@ inl(unsigned short port)
+ return xf86ReadMmio32Le((void *) ioBase, port);
+ }
+
+-#elif defined(__arm__) && defined(__linux__)
+-
+-/* for Linux on ARM, we use the LIBC inx/outx routines */
+-/* note that the appropriate setup via "ioperm" needs to be done */
+-/* *before* any inx/outx is done. */
+-
+-#include <sys/io.h>
+-
+-static __inline__ void
+-xf_outb(unsigned short port, unsigned char val)
+-{
+- outb(val, port);
+-}
+-
+-static __inline__ void
+-xf_outw(unsigned short port, unsigned short val)
+-{
+- outw(val, port);
+-}
+-
+-static __inline__ void
+-xf_outl(unsigned short port, unsigned int val)
+-{
+- outl(val, port);
+-}
+-
+-#define outb xf_outb
+-#define outw xf_outw
+-#define outl xf_outl
+-
+ #elif defined(__nds32__)
+
+ /*
+--
+2.22.0
+
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
index 06632b6..75d4076 100755
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
@@ -3,7 +3,10 @@ require recipes-graphics/xorg-xserver/xserver-xorg.inc
SRC_URI[md5sum] = "1509a9daae713895e7f5bcba8bcc05b2"
SRC_URI[sha256sum] = "0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457"
-SRC_URI += "file://0001-sysmacros.h-follow-changed-include-files.patch"
+SRC_URI += " \
+ file://0001-sysmacros.h-follow-changed-include-files.patch \
+ file://0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch \
+"
# These extensions are now integrated into the server, so declare the migration
# path for in-place upgrades.