summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2013-11-05 11:22:36 +0100
committerStefan Agner <stefan.agner@toradex.com>2013-11-05 12:47:52 +0100
commitab6e0b92aad480dd57431e915dd26aa0da5a4ea8 (patch)
treee4d0eb56e8d31e078e653813a5e7c066dd29291b /recipes-kernel
parentcdaa10d050b1239d55a087ccabaf42053a550a4c (diff)
Use double-quotes to make script work using dash (debian/ubuntu default)
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-vf_git.bb2
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb6
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-toradex-vf_git.bb b/recipes-kernel/linux/linux-toradex-vf_git.bb
index 88a6be3..540c924 100644
--- a/recipes-kernel/linux/linux-toradex-vf_git.bb
+++ b/recipes-kernel/linux/linux-toradex-vf_git.bb
@@ -31,7 +31,7 @@ config_script () {
do_configure_prepend () {
#use the defconfig provided in the kernel source tree
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
- DEFCONFIG=`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`
+ DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
oe_runmake $DEFCONFIG
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
index 6648ac0..478047d 100644
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ b/recipes-kernel/linux/linux-toradex_git.bb
@@ -36,7 +36,7 @@ config_script () {
do_configure_prepend () {
#use the defconfig provided in the kernel source tree
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
- DEFCONFIG=`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`
+ DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
oe_runmake $DEFCONFIG
@@ -46,7 +46,7 @@ do_configure_prepend () {
kernel_do_compile() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- export CC=`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`
+ export CC="`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`"
oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
@@ -55,7 +55,7 @@ kernel_do_compile() {
do_compile_kernelmodules() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- export CC=`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`
+ export CC="`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`"
if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
else