summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-03-08 17:53:44 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 11:00:11 +0200
commiteccf5986c3ab690ebc146db7bc26f4d0263c6ef1 (patch)
tree61a0d2e5c2a57bfaf37d9298b8654abe489ed111 /recipes-kernel
parent51ba50eb2edb1da0a21792085b18752f05a53b3c (diff)
kernel: hack, CFLAGS should not require contradicting soft and hard float
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
index 4aff790..994e268 100644
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ b/recipes-kernel/linux/linux-toradex_git.bb
@@ -43,3 +43,22 @@ do_configure_prepend () {
#maybe change some configuration
config_script
}
+
+kernel_do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
+ export CC=`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`
+ oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
+ if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
+ gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
+ fi
+}
+
+do_compile_kernelmodules() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
+ export CC=`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`
+ if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
+ oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
+ else
+ bbnote "no modules to compile"
+ fi
+}