summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb15
1 files changed, 1 insertions, 14 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 5dba294..56caa08 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -9,12 +9,7 @@ DEPENDS = "mtd-utils"
include conf/tdx_version.conf
inherit tegra-u-boot-localversion
-COMPATIBLE_MACHINE = "(apalis-t30|apalis-tk1|colibri-t20|colibri-t30)"
-
-DEFAULT_PREFERENCE_apalis-t30 = "1"
-DEFAULT_PREFERENCE_apalis-tk1 = "1"
-DEFAULT_PREFERENCE_colibri-t20 = "1"
-DEFAULT_PREFERENCE_colibri-t30 = "1"
+COMPATIBLE_MACHINE = "(apalis-tk1)"
FILESPATHPKG =. "git:"
@@ -59,10 +54,6 @@ install_unlock_emmc() {
install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
}
-do_install_append_tegra3() {
- install_unlock_emmc
-}
-
do_install_append_tegra124() {
install_unlock_emmc
}
@@ -71,10 +62,6 @@ do_install_append_tegra124m() {
install_unlock_emmc
}
-pkg_postinst_ontarget_${PN}_colibri-t20 () {
- grep u-boot-env /proc/mtd | awk '{print "/dev/" substr($1,0,4) " 0x00000000 0x00010000 0x" $3 " 1" >> "/etc/fw_env.config" }'
-}
-
do_install_class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv