summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend2
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb2
-rw-r--r--recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb2
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb8
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb6
6 files changed, 12 insertions, 12 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
index 05bfa70..324b51b 100644
--- a/recipes-bsp/alsa-state/alsa-state.bbappend
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/alsa-state/:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/alsa-state/:"
#make this machine specific, as we have different codecs with different settings
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index a46cffe..440ef6c 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -14,7 +14,7 @@ PV = "1.7"
EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
-EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
+EXTRA_OEMAKE:class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb b/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb
index 3eafcc7..c22bf20 100644
--- a/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb
+++ b/recipes-bsp/tdx-k20-fw/tdx-k20-fw_1.5.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENCE;md5=a1b1cf31b1b3d185409f31cb9beb25dc"
-FILES_${PN} = " /lib/firmware/apalis-tk1-k20.bin "
+FILES:${PN} = " /lib/firmware/apalis-tk1-k20.bin "
do_install () {
install -d ${D}/lib/firmware/
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index bf00d65..02c789e 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -12,7 +12,7 @@ SRC_URI = " \
git://github.com/NVIDIA/tegrarcm.git \
file://0001-makefile-specify-cryptopp-include-path-relative-to-s.patch \
"
-SRC_URI_append_class-native = " \
+SRC_URI:append:class-native = " \
file://0001-configure.ac-link-crypotpp-as-a-static-library.patch \
file://0001-cryptopp-use-relative-path-for-cryptopp-headers.patch \
"
@@ -22,10 +22,10 @@ PV = "1.7+"
EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
-LDFLAGS_append = " -static-libstdc++"
+LDFLAGS:append = " -static-libstdc++"
-EXTRA_OEMAKE_class-native = "CC='${CC}' CXX='${CXX}'"
-EXTRA_OEMAKE_class-nativesdk = "CC='${CC}' CXX='${CXX}'"
+EXTRA_OEMAKE:class-native = "CC='${CC}' CXX='${CXX}'"
+EXTRA_OEMAKE:class-nativesdk = "CC='${CC}' CXX='${CXX}'"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
index d1bc364..7350b5d 100644
--- a/recipes-bsp/tegrastats/tegrastats.bb
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -9,13 +9,13 @@ S = "${WORKDIR}"
# Inhibit warnings about files being stripped.
# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
-INSANE_SKIP_${PN} = "already-stripped build-deps file-rdeps ldflags"
+INSANE_SKIP:${PN} = "already-stripped build-deps file-rdeps ldflags"
do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/tegrastats* ${D}${bindir}/
}
-FILES_${PN} = "${bindir}/tegrastats"
+FILES:${PN} = "${bindir}/tegrastats"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "tegra124"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
index ade3907..7e772bf 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
@@ -4,13 +4,13 @@ require recipes-bsp/u-boot/u-boot.inc
B = "${WORKDIR}/build"
DEPENDS += "bc-native dtc-native"
-DEPENDS_append_apalis-tk1 = " cbootimage-native"
+DEPENDS:append:apalis-tk1 = " cbootimage-native"
PROVIDES += "u-boot"
COMPATIBLE_MACHINE = "(apalis-tk1)"
-SRC_URI_append_apalis-tk1 = " \
+SRC_URI:append:apalis-tk1 = " \
file://apalis-tk1.img.cfg \
file://fw_env.config \
file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
@@ -18,7 +18,7 @@ SRC_URI_append_apalis-tk1 = " \
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_deploy_append_apalis-tk1() {
+do_deploy:append:apalis-tk1() {
cd ${DEPLOYDIR}
cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img